File Sharing - Administrator's rights etc.

  jimforrest 19:35 04 Oct 2013
Locked

With the help of the chaps on here I am reloading Win7 on my Samsung Laptop but I've hit a snag with file sharing. It seems that the only way I can share files across my little home network is by setting up a HomeGroup - but that requires a password. There is only me on the network and I don't want to put passwords in every time I want to do something. I am listed as 'User' and I suspect that this is why I can't set it up. How do I change User to Administrator? My network can 'see' the other comps but I can't do anything because 'I don't have permission!'

  Fruit Bat /\0/\ 20:01 04 Oct 2013

How to Grant Permissions in Windows 7

  1. Locate the file or folder on which you want to take ownership in windows explorer
  2. Right click on file or folder and select “Properties” from Context Menu
  3. Click on Edit button in Properties windows Click ok to confirm UAC elevation request.
  4. Select user/group from permission windows or click add to add other user or group.
  5. Now under Permission section check the rights which you want to grant i.e check “Full Control” under the “Allow” column to assign full access rights control permissions to Administrators group.
  6. Click Ok for changes to take effect and click ok final ok to exit from Properties window.

Now you can access files of folder in windows 7 with full permissions and take full control.

  jimforrest 23:02 04 Oct 2013

Ok Fruitbat - done that. Now I can 'see' the folders on both comps, but I can only access some of them. Some just open into the subfolders, whilst others immediately say that I do not have permissions to open them. I have turned UAC off on both comps (by moving the slider to the bottom), and gone to each folder and allowed sharing by everyone (on both comps). Yet some folders remain 'unshared'.

  Fruit Bat /\0/\ 12:51 05 Oct 2013

How to Take Ownership in Windows 7

  1. Locate the file or folder on which you want to take ownership in windows explorer
  2. Right click on file or folder and select “Properties” from Context Menu
  3. Click on Security tab
  4. Click on “Advance”
  5. Now click on Owner tab in Advance Security Settings for User windows
  6. Click on Edit Button and select user from given Change Owner to list if user or group is not in given list then click on other users or groups. Enter name of user/group and click ok.
  7. Now select User/group and click apply and ok. (Check “Replace owner on subcontainers and objects” if you have files and folder within selected folder)
  8. Click ok when Windows Security Prompt is displayed
  9. Now Owner name must have changed.
  10. Now click Ok to exist from Properties windows
  Woolwell 13:26 05 Oct 2013

Have you set file sharing on both computers? Sometimes the firewalls can also create the problems you are experiencing. Both computers should join the home network. You should only have to enter a password if you have set up a password on each computer. The network recognises devices and not really users.

  jimforrest 13:33 05 Oct 2013

OK Fruitbat - but the problem is that when I try to 'see' or transfer the folder contents over the network to my other laptop it says that I don't have permission. Is the problem that the sharing routine you describe above has to be done on both laptops, but they have different names? Therefore the name on the requesting laptop isn't the name of the owner of the file on the donor laptop.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?