File Name Extension

  dnjl 16:07 29 Nov 2007
Locked

How do I stop all my files showing their extension name please? i.e. Lake Lucern.jpg - I want it just to show Lake Lucern.
or my paper ones - Files List 2007.wps instead of Files List 2007

This is so annoying.

  wee eddie 16:15 29 Nov 2007

Open My Docs > Click on Tools > Folder Options > View > enable 'Hide Extensions for known file types'

  dnjl 17:06 30 Nov 2007

Thanks a lot. Why is it a lot safer please?

  Kemistri 17:26 30 Nov 2007

Some people would say that it is probably safer to keep extensions hidden. If the author of a malicious file attempts to use the rather obvious method of adding what looks like an innocuous file extension to the file name, it will stick out among files that lack suffixes. For instance, harmless.jpg (among files without suffixes) will hopefully stand out more than harmless.jpg.exe among other files that all have suffixes. You might not spot that double suffix. Other people prefer the opposite, but for much the same intention; they keep suffixes displayed as their way of spotting files that may use that method of obfuscation. I have to say, though, that I have not seen any malicious files with extra suffixes, so I think maybe it's not very common. I don't know which method is better in practice and I don't worry about it at all; that's what anti-virus apps are for. Think before you download files from untrusted sources and I can't see a problem.

  terryf 00:26 01 Dec 2007

If you retain the suffixes, you will be able to tell the difference between 2 files with the same name, one might be an exe file and one (for instance) a dll file. A lot will depend on which view you use, I use detail view for folders that don't contain pictures and thumbnails for the folders filled with downloads from my camera, etc. I use icons for folders like Control Panel.

  ashdav 01:32 01 Dec 2007

Whoever created the file may have included the extension (file type) in the name of the file.
If this is the case then just right click on it and rename it.
If you get a prompt from Windows that altering the extension/file type may prevent it from working then you need to go to Control Panel/Folder Options/View
Then tick the box that says "Hide extensions for known file types"

  dnjl 12:48 01 Dec 2007

Thanks to everyone for that info. Another problem solved.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse's new logo: the trainer brand looks to its heritage for a fresh identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans ├ęchec ?