file extension restore?

  onlymeagain 01:42 10 May 2005
Locked

Hi, i was using Sage line50 on windows 2000, i am not too familiar with this, i made a backup, managed to find it, and decided to double click it to see if it saved my information correctly. I got a dialogue box up saying "open with..." so i decided to choose notepad, and foolishly realised after ticking the box that said "always use this program" That it has converted the original backup file to a text file, so now when i ask sage to restore my backup it says it cannot convert it (as its a *.txt format) anybody know how to restore original extension e.g registry restore/fix perhaps??
thanks

  DieSse 01:47 10 May 2005

You can simply delete the txt part and type in whatever the extension name should be, in explorer.

If the extension name is not displayed, use the Options in Explorer to turn on the display first.

  onlymeagain 01:53 10 May 2005

thanks
i think i tried that, think the original extension was *.001 I tried renaming the file, but it didnt seem tomake a difference, just renamed it as sagebackup.001, but the icon still shows as a txt document

  DieSse 02:18 10 May 2005

If you don't turn on the display for file extension names, you may not have renamed it correctly.

What the icon is is pretty irrelevant, it's whether Sage recognises it as it's backup file, which presumably it will if you change the extension name correctly (that's how it knows).

It is possible that opening it with Notepad, if you then saved it, might have destroyed it's use as a Sage backup file - I don't think this will have happened, but if it has, you have lost the file for ever.

  pauldonovan 12:09 10 May 2005

..the file with Notepad and now needs to de-associate it ?

Of course to do that you really need to know if/what it was associated with originally.

  pauldonovan 12:10 10 May 2005

..if double click brought that dialog box up then it is fairly certain the file wasn't associated with anything.

In which case you probably can't view it that way in explorer and will need to use a sage tool to get into it.

  pj123 12:53 10 May 2005

Make a New Folder (called Sage Backups?).

Now run Sage again and do another backup and point it to save in the new folder. Once that is done you can delete the other backup.

  DieSse 15:48 10 May 2005

"Isn't the problem just that he has associated..
..the file with Notepad and now needs to de-associate it ?"

It's the extension name that governs associations - changing the extension name should change the association too.

But I don't think Sage will make an association - it doesn't need to - it just needs to know where it's backups are, and how they are named. That's why there was no association in the first place.

  onlymeagain 10:17 11 May 2005

thanks folks,i done a bit of what everyone said and it seems to have worked
cheers

  pauldonovan 10:49 11 May 2005

I know how associations work. I was just thinking that if sage doesn't make an association in the first place then I'd be surprised if renaming the file is going to help.

  DieSse 13:00 11 May 2005

"I'd be surprised if renaming the file is going to help."

Renaming the file will help, as renaming it back to what sage expects, will enable sage to find it again - it'll not find it with the wrong name.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Microsoft Surface Book 2 hands-on review – bigger and 5x faster

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?