File Association

  Les 15:56 26 Feb 2007
Locked

My neighbour when trying to associate his data files (ext '.ttp') wrongly clicked a folder with the same name TTP. Of course, the data files will not open when clicked directly. OK - it would seem that he just has to delete this false association and remake with the correct one. Unfortunately, when the incorrect association is highlighted the Delete button is greyed out - all other entries listed under File Types when highlighted have the delete but live.

Tried the Help/Appearance and theses/folder options/file types etc this allowed me to enter, under New, the ext .ttp clicked change and broiwse to the program required to open the data files.

This had no effect for the ttp folder was still listed and it cannot be deleted - the delete button being greyed out!

Suggestions regarding a workaround this problem would be appreciated for, it seems to me, that the folder ttp must be deleted first. My own file association box works properly using the same methods as he is using.

  Terry Brown 16:50 26 Feb 2007

Has he tried right clicking the file and using 'open with' the correct setting and changing that to default.
Terry

  Les 17:35 26 Feb 2007

Yes indeed he has. I believe the fact that he associated a folder instead of a program file is the root of the problem. The delete option in the box used to associate files and opening programs is greyed out and so won't work when that folder name in the list is highlighted. Other associations can be deleted

A registry problem perhaps?

  VoG II 17:36 26 Feb 2007

Try a System Restore.

  Les 22:30 26 Feb 2007

Thanks VOG (and Terry Brown) for your replies.

Sorry for the delay but he has kept me busy - the dealer he bought the computer from had reinstalled Windows XP - it only had SP1 installed so SP2 and updates have needed loading - plus other problems to solve. This leaves him with the current problem

The computer was returned to him this morning and it had no restore points set.

I am convinced that the problem is brought about by his over-enthuastic clicking of the mouse button - he saw a TTP icon (which I know is not the executable file) and clicked it as the program to open his data files. It appears now that this incorrect program cannot be deleted by normal means for, when selected, it simply disables the delete key!The delete key is not disabled for other entries in that list.

Fortunately, he can still access his data files by loading the executable file first and then loading the data files from that.

I wonder if there is a way of deleting that incorrect TTP entry from the list of file associations.

  Les 09:04 27 Feb 2007

bump

  Les 13:41 01 Mar 2007

My neighbour is still fretting that he cannot click on a data file with that extension .TTP in oder to open the file!

I would like advice on the files where the registry info is stored.

Such as what are the files named? I believe that one used to be user.dat but whether or not that is so now I have no idea.

As his registry file appears to be corrupt in that it will not allow the deletion of the offending file name (in Explorer/Folders/File Types) then I'm wondering if the two files I've mentioned could be copied from my computer to his and solve the problem - what do you think?

  Les 11:54 02 Mar 2007

He's not content with accessing his data files from the application itself. Personally I can't see why.

He has decided to return the computer to the shop and, as it is a self inflicted wound, he will have to pay. Perhaps he will curb his impetuosity in future - but I doubt it 8-))

No doubt they will replace the file(s) in which the registry info is stored (?) -

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?