Far Cry DVD

  tooter 09:57 22 May 2004
Locked

I can’t get the DVD ROM of a game called FAR CRY to load, I place the DVD in my Hitachi DVD-ROM GD 8000 drive and all that happens is that I get a spinning disc next to the curser and nothing else happens? I have checked that the DVD is registered for the UK market, other DVDs run perfectly in the drive. (XP Pro, NVIDIA GeForce2 Ultra Card) can anyone help? Thanks

  sicknote 10:08 22 May 2004

Have you tried browsing the CD and doing a manual install using the setup.exe ??

  sicknote 10:10 22 May 2004

Have you tried here for help or patches click here

  Arthur Scrimshaw 10:13 22 May 2004

There are known issues with this game and certain DVD drives (mainly from LG) On the read me file for the game it suggests downloading the latest drivers, alternatively go to click here for more information.

Good luck - it's a brilliant game and worth gfetting sorted out. (I'm on my second run through it and I'm just as hooked as the first time!)

  tooter 12:10 22 May 2004

Hi Sicknote
If I try to browse the disk by right clicking on the drive all I get is the egg timer and have to press ctrl,Alt.del to exit the operation and then get a message say the programme is not responding, so I am able to open browse or to see any files etc. that are on the disc.

  sicknote 12:29 22 May 2004

can you not view the disc using win explorer?. if you can't view the disc then theres no chance of the drive using it.Have you try the disc on another PC,cleaned it and checked for damage ???

  Arthur Scrimshaw 13:25 22 May 2004

I have checked the Far Cry Forums and there are other people with this problem that have the Hitachi GD 8000 drive. They haven't found a solution to the problem.

  tooter 17:05 22 May 2004

It looks like 34 quid down the pan thanks for all your help

  sicknote 17:46 22 May 2004

Have you upgraded your firmware to 0010 It can be done from click here

  platty100 18:10 22 May 2004

have you tried changing your dvd drive to "pio" insted of "dma" in device manager/ ide controllers you can change it back after ( worked for me )

  helmetshine 18:46 22 May 2004

I had a problem with this game not running(kept saying i had cd emulator running...evidently it's a common problem with this game and various burning software)the solution i found was to use a NOCD patch.
i know these things are normally frowned upon in these forums as they can be used to play cracked games but i feel in these circumstances it was a legitimate use as i had bought the game but was unable to play it
I was wondering if a similar patch would solve tooter's problem as his game then wouldn't need to access the dvd If you go this route the patch needs to overwrite the Farcry.exe in the 32bin folder

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment créer, modifier et réinitialiser un compte Apple ?