Failure to update ATI Drivers

  thumbscrew 19:35 26 Jul 2009
Locked

I'm trying to update my ATI Catalyst Drivers 9.7. I use XP and when I begin the update it shows two options...Folding Home and ATI Drivers. I've tried both of them and, in each case the same thing happens: half way through the installation it stops and displays this message..." Set up did not find a driver compatible with your current hardware or operating system, it will now exit".Can anyone help please?

  fishmad pete 19:54 26 Jul 2009

The folding home option is a free bit of software and does not have anything to do with the drivers.
Which graphic card are you using?

  Stuartli 20:04 26 Jul 2009

ATi has stopped support for older cards. See:

click here

to see if your card is perhaps among them.

It may release critical updates as or if necessary.

  thumbscrew 20:04 26 Jul 2009

Cheers Pete, unsure which card...is there a swift way to find out?

  fishmad pete 20:19 26 Jul 2009

Right click on a blank area of the desktop and chose properties in the drop down list. This should bring up the display properties box. Select the settings tab and hopefully in the display box should be listed your graphics card.
Alternatively go into control panel and select system. Select the hardware tab and then the device manager. Select display adaptor and again your graphics card should be listed there.
I recently had a problem when installing a graphics card to a new motherboard fitted with onboard graphics. In accordance with the motherboard quick install instructions I fitted the card prior to starting the computer for the first time. This prevented a few PCI bus drivers from loading and resulted in the ATI driver software not finding the graphics card. I removed the PCI express card and booted the computer up using the inbuilt graphics. All drivers where loaded correctly. I then refitted the graphics card and installed the drivers for it.

  sunnystaines 20:21 26 Jul 2009

i updated to 9.7 ok yesterday, always delete the folding home bit afterwards.

the driver updated ok over 9.6.

  thumbscrew 20:23 26 Jul 2009

Thanks all...Radeon x800GT

  Audio~~Chip 20:26 26 Jul 2009

division. Firstly I would get the ATI removable utility from AMD ATI site. If this is a clean install of XP or Vista then install all Netframework 2 & 3 first as ATI Drivers require this. Also in XP you need at least SP2 and Vista SP1 minimum

  fishmad pete 20:33 26 Jul 2009

The X800 is in the un supported list. The latest Driiver for this card is 9.3 perhaps the 9.7 is for the newer cards and that is why it can't find your card

  thumbscrew 20:35 26 Jul 2009

Very good of you all to help. Actually everything's fine and dandy at the present, so what's the worst possible scenario if I don't update at all, thus preserving my digestive system, nervous system and sanity?

  Stuartli 22:37 26 Jul 2009

The 9.3.1 driver is the final driver for unsupported ATi graphics cards.

I only use the ATi driver and, instead of the bloated Catalyst software, use ATi Tray Tools, which does pretty much the same with a much smaller download of 1.5MB. See:

click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Adobe shows still-in-development tools, including automatically colourising black-and-white photos

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?