Failed to query TCP/IP settings.

  donfrench 19:36 04 Oct 2007
Locked

New system (KN3-SLI2 mobo with an Athlon 64X2 Dual Core 5600+), fresh install of XP Home SP1, no other software of any kind installed. Connected a CAT6 cable between my router and the 1394 port and tried to connect to the internet. Used same cable with my laptop with no problems. But now I cannot connect even though the 1394 status is "Connected". I tried "repairing" the connection and got "Failed to query TCP/IP settings of the connection. Cannot proceed" I tried running ipconfig /all in a command window and got "Windows IP Connection" and not one other character.

I saw another thread on this site about this but the solution offered (netsh winsock reset) does not work with SP1 apparently, as netsh does not recognize winsock as a command.)

Before trying this, I had installed XP Pro x64 Edition and had the same problem, which is why I decided to try a fresh install of XP Home to see if it was x64 causing the problem. So, it looks like a hardware issue with the 1394 port to me but I am not sure. Anyone have an opinion/solution to this problem? Thanks.

  mgmcc 19:54 04 Oct 2007

The "1394" Connection in the Network Connections folder is *FIREWIRE*, always shows as Connected even though it isn't physically connected to anything and has nothing to do with an ethernet connection between the PC and the router.

The "Local Area Connection" in the Network Connections folder is your ethernet link to the router.

  donfrench 20:09 04 Oct 2007

Oh god! I knew that and I completely forgot it. I feel foolish! I think it happened because 1394 was the only device to appear under Network Adapters in the Device Manager and my mind slipped a gear because I was expecting to see the port there that I plugged the cable into.

Well anyway, "Local Area Connection" does not appear in the Network Connections folder either. So, XP is not seeing the ethernet port, not that it XP's fault. There are two ethernet ports on the mobo that appear on the back panel. Could I have missed something when I installed the mobo?

  skidzy 21:54 04 Oct 2007

First thing i would do,is to download and install sp2 click here reboot and connect the ethernet to the router and pc.

  donfrench 21:56 04 Oct 2007

Fer crissakes! I forgot all about the driver disk that came with the motherboard. Of course, all the necessary drivers were on there and now it works fine. Man, it sucks to get old and forget shit all the time. Yeah, laugh! Wait till you get to be 82 and see how many brain cells YOU have left. ;)

  donfrench 21:58 04 Oct 2007

Skidzy,

I fixed the problem, as I indicated in my previous post, but I would not be able to do as you suggested until the problem was already solved, because as I said, I couldn't connect to the internet, the problem I was trying to solve!

  skidzy 22:06 04 Oct 2007

As you where posting here,i thought you had access to another machine.
Thats why i suggested sp2 download and install on the problem machine.

Glad your sorted.

  donfrench 22:11 04 Oct 2007

Well, yes, I do have another machine that I am using but isn't that a pretty hefty download? More than a thumb drive for transferring it between computers could handle?

  mgmcc 23:28 04 Oct 2007

The full SP2 installation file is 266MB from click here

  donfrench 23:48 04 Oct 2007

OK, I thought it was a lot larger.

  skidzy 00:15 05 Oct 2007

Strange that,Softwarepatch has it as 272MB slightly larger than MS download.

The link i supplied is the one i use to download and burn to disc for those computers running sp1 after a reinstall.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?