External USB FDD stopped working

  Kiwi323 15:48 24 Dec 2007
Locked

I purchased an external USB FDD off Gizoo in August and the unit stopped working some time ago. When I plug it into my PC or laptop USB port, neither unit will recognise the FDD as being installed. Both PC and laptop run XP Pro. Is the FDD kaput?

  Technotiger 15:54 24 Dec 2007

Hi, looks like it, I also had one go belly-up when it was only a few months old. Still, you should be able to get another under the warranty.

  Fruit Bat /\0/\ 17:16 24 Dec 2007

you could try

Refresh USB Ports
In device manager Uninstall EVERYTHING under the heading USB,
reboot the PC let XP find and install new hardware.
Your equipment should now be recognised.

  Kiwi323 18:06 24 Dec 2007

Thanks Fruit Bat but that is something I have already tried, with no luck.

  Kiwi323 22:47 06 Mar 2009

Problem was solved after the FDD was replaced under warranty. Cheers guys.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment regarder des séries et talk-shows américains en France ?