external HDD access denied.

  Flying Teddy 21:39 27 Nov 2006

I have a desktop PC running XP Pro and a laptop running XP Home. I recently purchased an external usb hard drive with a view to backing up both HDDs in the desktop onto it, and also that in the laptop. I connected the external drive to the desktop and succesfully backed up both drives. I then connected it to the laptop and there was the usual whirring and clonking and the drive duly appeared in the explorer index pane. So far so good.

However, when I tried to access the external drive from the laptop, I get an error message saying that the drive is not accessible and access is denied (usual Big Brother M$ giving factually correct but completely useless error messages). I know the drive is OK because it works in the desktop. I Googled (is that a verb?) the problem and found many solutions. Most assumed that the problem machine runs XP Pro, and for those on XP Home, the alleged solutions involve booting in safe mode, wherein USB does not function! So no help there.

I reconnected the drive to the desktop and set the sharing so that any user can have access. I reset the drive letter on the laptop to match that of the desktop. None of this works. An interesting aside is that Diskeeper reports the cluster size on this 250GB drive to be 512 bytes. This seems unusually small to me. If it is correct, does this give XP Home a problem? On the laptop, the properties of the disk report zero size and zero free space. If it's at all relevant, I used Acronis True Image 7 to produce the image files.

I've trawled the PCA archives, but I can't readily see that the problem has been reported before. Therefore it would seem that I am doing (or not doing) something stupidly obvious in order that the disk can be used on both machines. Can anybody tell me what that thing is? Please? Pretty Please?

After all, what's the use of having a removeable item if it can't be moved?

  lotvic 23:10 27 Nov 2006

A shot in the dark... 'cos not got an external HD but I do know that in XP pro when denied access it is because of 'Simple File Sharing' and you have to Untick this before the 'security' tab will show to enable you to take ownership/ change permissions of files.
Tools > Folder Options > View > the last in the list 'Use simple file sharing

It may (or may not) have something to do with it.

  Flying Teddy 18:04 28 Nov 2006


Thank you for your thoughts - I had actually seen that, but the problem is on the machine with XP Home, which doesn't display simple file sharing as an option, neither does it have the 'security' tab and therefore will not let me take ownership. So that's a bit of a dead end I'm afraid. Hey ho...

  Fruit Bat /\0/\ 18:39 28 Nov 2006

go to user accounts make a new account with admin rights and password protected.

then go to configuartion panel and go to users and passwords be sure that you are admin on you own pc

Then login with that account go to properties of that HD and check if the user what you have made have full access to the drive.

  Flying Teddy 19:45 28 Nov 2006

Fruit Bat /\0/\,

OK I've tried that, new accounts on both m/cs, no change. Full access indicated on the desktop, but still no obvious way of changing (or even finding out) access rights on laptop XP Home. I'm missing something quite basic here, but I've no idea what!

  Flying Teddy 21:26 09 Dec 2006

Well I solved it. The problem seems to have been that the external drive was FAT32 formatted. As a normal step when using XP, I converted it to NTFS and Hey Presto, all is sweetness and light. Although I am still hazy as to why XP Home (OEM) should dislike a single large FAT32 partition on an external drive and XP Pro (retail) is OK with it.

Thank you for all your contributions.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

How to update iOS on iPhone or iPad

Les meilleures applications pour enfants 2017