external hard drive problems

  blueforever 15:14 30 Mar 2008

hi can any one help i have aprob with my external hard drive i keep getting delayed write fail all data is lost message its a new drive a maxtor 300 gig drive when i turn it on its ok but after a while iget the above message and all files go missing if i turn it off and back on its ok for a while then same thing happens took it back to shop they had it on and running with no problems drivin me potty am new to the pc world please help

  johndrew 16:10 30 Mar 2008

More details of the drive and how you have it connected and what to (laptop/PC direct USB/hub) would help.

  wee eddie 16:59 30 Mar 2008

The OS of the PC you are using it with, and what is your connection?

I assume that you are trying the do a back-up. What software are you using?

  blueforever 21:07 30 Mar 2008

sorry new to this drive connected to desktop pc bye usb 2 am using windows xp hope this helps

  johndrew 10:02 31 Mar 2008

If it worked OK at the shop but not on your PC and it is connected directly to a PC USB port, I would suggest it is the PC USB port you are using or the setup. Have you tried an alternative USB port?

What format is the external drive, FAT32/NTFS?

  wee eddie 10:31 31 Mar 2008

remember to use the "Safely Remove Hardware" Procedure.

Failure to do so, could trash your drive

  blueforever 14:01 31 Mar 2008

thanks for your responce dont know what format my drive is it was formatted at the shop have taken your advice and tried a diff usb port thought it had sorted it but after about 1 hour got same message stuck again thanks

  wee eddie 14:42 31 Mar 2008

are you using Software or Copy & Paste?

  blueforever 16:15 31 Mar 2008

sorry i am a bit mixed up now what i want to do is view my files on external drive i swped round usb ports and it was ok for about an hour then i got message delayed write fail all data lost not trying to transfer data to anywhere just using drive as storage sorry about this as i said a newbie to all this thanks

  johndrew 16:44 31 Mar 2008

I have done more digging and think I may have a cause and solution click here. Go to the `Resolution` paragraph and disable caching for the external drive then see how it goes.

  johndrew 16:51 31 Mar 2008

I also found these, but they don`t appear to help a lot compared to the MS link.
click here
click here
click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

How to find a font: Discover the name of a typeface with these apps

The best iPhone for 2017

Comment créer un compte PayPal pour payer en ligne ?