External Hard Drive Problem

  Ze3 19:53 22 Mar 2008
Locked

Hi all

I have an external hard drive which i have connected to my laptop nearly all the time. THe model is a

Seagate FreeAgent Desktop 500GB 3.5" External Hard Disk Drive

It has worked fine for the past few months. Earlier today i was using with no problems. I then needed to move so disconnected the laptop and the external hard drive and mvoed. When i plugged it in, i had a weird sound come on rather than the usual sound when loading up the hard drive.

The sound i can only describe is like a whurring sound which then clicks when it gets to its peak. after a few of these series i get a beeping noise whilst the hard drive is still whurring, this beeping noise happens about 10 times, then the whurring noise occurs for a long period of time. This process happens over and over again.

If i have it connected to the laptop, i cannot reach the screen to log in to Windows Vista whereas if i do not have it plugged in the laptop conitinues to run fine. I loaded the laptop up without it plugged in and then tried putting it in once it had loaded. The noises still occurred and when looking in my computer it did not show that any drive was connected. I now have an external hard drive making a beeping noise and whizzing round but i am unsure what i can do. Any suggestions will be appreciated.

Mike

P.s When the whurring noise hits its peak the light on the external hard drive goes off, then reappears as the noise starts again

  Jak_1 20:23 22 Mar 2008

From what you describe it sounds like there is a major fault with the drive, or, damaged power conection. Did you let the drive spindown before moving it?

  Ze3 20:24 22 Mar 2008

if u mean by 'spindown' letting it turn off and stop whizzing around then yes, then moved it like i have done before

  Ze3 21:01 22 Mar 2008

any other options?

  Jak_1 21:07 22 Mar 2008

How old is the drive?

  woodchip 21:10 22 Mar 2008

It sounds like you disconnected it without using safely remove device in system tray. So it looks like it's corrupted the drive. Try downloading Seagate Seatools Load in a floppy by double clicking the file then start with disc in drive. USB drive connected and switched on.

Seatools click here

  Ze3 22:04 22 Mar 2008

can any1 get me adirect link,

much appreciated

  MCE2K5 22:11 22 Mar 2008
  Simsy 09:55 23 Mar 2008

It's the "autoplay" feature checking the contents of the drive before deciding which options to present you with as to what you want to do. If there's a lot of content on the drive this might take a while?

Regards,

Simsy

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Comment afficher des fichiers cach├ęs sur Mac ?