External hard drive problem

  FatboySlim71 14:33 05 Feb 2008
Locked

I have just purchased an Icy Dock MB559US-1S ESATA/USB 2 enclosure and a 500 GB hard drive.

The problem I have is this. If I go into My Computer the Icy Dock/hard drive is not shown, the main C drive is. But if I go into the device manager the Icy dock enclosure/hard drive are shown. I have also looked in the BIOS and the Icy Dock enclosure/hard drive are shown in there too.

I clicked on scan for changes in the device manager but this did not help. Can anyone help me out please.

does it appear in disc management,try assigning a different letter to it.
click here
is it set to master or slave?

  BurrWalnut 14:57 05 Feb 2008

If it's brand new, it needs formatting:

Right-click My Computer > Manage > Disk Management. Right-click the new drive graphic and partition/format it.

  FatboySlim71 15:22 05 Feb 2008

Thanks everyone especially BurrWalnut, yours was the correct answer. I can't believe I was so stupid to overlook formatting, although I have never had to install a SATA hard drive/enclosure before. Thanks very much again for the help.

  FatboySlim71 15:23 05 Feb 2008

The drive is now showing up when I go into my computer. Thanks again.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Converse's new logo: the trainer brand looks to its heritage for a fresh identity

Mac power user tips and hidden tricks

Comment lancer Windows 10 en mode sans ├ęchec ?