External hard drive prevents boot up

  belayer 19:46 28 Sep 2007
Locked

I have just bought a Maxtor 3500 external hard drive, 500Gb. I use Windows XP.

With the Hard drive connected and power on the PC won't boot up, it just says 'NTLDR missing'. If I connect the hard drive after boot up its fine.

It ought to be possible to keep it connected all the time.

Any ideas?

  davidh50 19:54 28 Sep 2007

See if these Links Help.

click here
click here

  jameth182 19:55 28 Sep 2007

Have you tried looking at the HDD management through My Computer because I'm sure I had a problem similar and i sorted it through there ...

Just an idea, might work

  davidh50 19:57 28 Sep 2007

Also try Turning off 'USB Legacy Support' in the BIOS.

It worked for me.

  Confab 19:58 28 Sep 2007

Check the boot sequesnce in the bios and ensure that its not set to boot from an external device first.

  fishface113 19:59 28 Sep 2007

Check your bios!

On most modern PC systems the bios will allow a boot from usb devices. Simply remove anything that you do not wish to boot from. eg floppy disk/cd/scsi/any other device. As a bonus it will also inprove your boot speed.

I have a western digital external 250gb drive, and it used to do the same.

  belayer 20:23 28 Sep 2007

Thanks for all the advice but, how do I check/change the BIOS?

It sounds a bit complicated.

  fishface113 20:27 28 Sep 2007

Ussually hold F2 on the boot up screen. This will enter the BIOS setup.

If you haven`t done this before then be careful because you can mess up your machine while altering things. If it goes wrong just "load default settings" and restart the machine.
This will set everything to original specs.

  belayer 20:52 28 Sep 2007

Well, I tried all that, the only booting devices I can see are the Internal HD and CD in that order, nothing else. I have turned the USB legacy 'OFF', but its still the same.

Jameth182, where do I find what you are referring to?

  belayer 21:10 28 Sep 2007

I went to the Compaq website and downloaded the latest BIOS update - it works!!!!

It was an update intended to solve a boot problem with a particular model of USB printer connected, but it worked anyway.

Thanks everybody!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Microsoft Paint set to die after 32 years

Mac power user tips and hidden tricks

Comment désactiver la saisie intuitive et paramétrer votre clavier ?