External Hard Drive not accesible

  drummer 22:12 04 Aug 2007
Locked

Hi Guys
I have an external usb2 drive that has run ok for 6 months. It will not now show in my computer although if I check device manager it is there, I have so far tried uninstalling and searching for new hardware many times and although device manager sees it, my computer does not. I have read a few threads and have tried uninstalling all usb devices and rebooting, still no go.
Unplugging and replugging also tried but still nothing. Very frustrating!
Any further ideas greatly apreciated.
Drummer

  ambra4 05:34 05 Aug 2007

Have you try using a different USB port,

Examine the properties for the USB drive and see if you have a "removable" check box.

A USB external drive should have a check in this box.

Reboot and see what happens.

  drummer 22:58 14 Aug 2007

tried all sorts of things...however faulty drive enclosure was one of the last.
Thanks anyway

  woodchip 23:02 14 Aug 2007

The partition on the Drive is Corrupt, Probably Due to pulling the USB plug instead of right clicking icon in system tray and use Safely Remove Hardware. You cannot do this with a Drive, as windows will be writing to the drive.

  sunny staines 16:20 15 Aug 2007

click here

not used it. but looks like it may help you out.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Adobe shows still-in-development tools, including automatically colourising black-and-white photos

iPhone X news: Release date, price, new features & specs

Comment transformer un iPhone en borne Wi-Fi ?