External Hard Drive Error-Need Help!

  SummerLady 03:16 31 Dec 2009

I have an Iomega 1TB external hard drive that I have been using. It has worked fine. I went to hook it up to my laptop and got an error "USB Device Not Recognized" and when I go into device manager and check properties I get a "code 43" error. I've used it many times on my PC and now it's not working on the PC or laptop. My laptop is a Dell Inspiron running Windows 7

Desktop is a Dell XPS 400 running Windows

Can anyone tell me how to fix this so I can access all my stuff saved on my hard drive.


  michaelw 08:36 31 Dec 2009

A "code 43" error is usually a driver issue. I don't know about windows 7 but in xp you look in device manager for a 'yellow' and reinstall the driver.

Can you use any other usb device in that port?

  rawprawn 09:39 31 Dec 2009

Go to Device manager and uninstall the driver for that device, then reboot your computer it will automatically reinstall the driver.

  SummerLady 16:29 31 Dec 2009

I tried updating the driver and that didn't work as well as trying a new USB port.

I'll try uninstalling it and reinstalling it and see if that works.


  ICF 16:31 31 Dec 2009

If it's a driver error then why is it not working on the laptop and the PC
It looks like it's knackered to me

  Fruit Bat /\0/\ 17:39 31 Dec 2009

Code 43
Windows has stopped this device because it has reported problems. (Code 43)
Recommended resolution

One of the drivers controlling the device notified the operating system that the device failed in some manner.

If you have already run the Troubleshooting Wizard, you might want to check the hardware documentation for more information about diagnosing the problem.

  SummerLady 03:18 01 Jan 2010

Well I tried uninstalling and updating my drivers and it's still saying the device is unknown.

This sucks, I have literally hundreds of dollars of shows and music on this stupid thing and that's not including my pictures!

If anyone else thinks of anything I'm open but thanks for all the suggestions!

  SummerLady 03:19 01 Jan 2010

I tried plugging it into other USB ports and get the same error in every single one

  ICF 08:08 01 Jan 2010

Just a thought does it have an external power supply? is it powering up?

  SummerLady 08:15 01 Jan 2010

Yeah, I have it plugged in with the AC adapter and then the USB port and the light comes on and it makes the "powering on" sound so that much works *sigh*

  rdave13 08:36 01 Jan 2010

Shot in the dark but there may be a problem with the cable from the hard drive to the usb connection?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Intel Coffee Lake release date and specifications

12 Amazing British Craft Beer Label Designs

watchOS 4 review

Les meilleurs navigateurs internet 2017