External Hard Drive

  morddwyd 08:56 21 Nov 2010

Why would a 2.5 drive in an external caddy work in a desktop but not in a laptop?

I get the message "New hardware ready to use! but it simply doesn't appear.

  Forum Editor 09:07 21 Nov 2010

after the laptop has booted?

If you are, trying booting the machine with the drive connected.

  Fruit Bat /\0/\ 09:14 21 Nov 2010

Also a possible power problem from the usb port.

does it have two usb cables or a external power cable?

I often find these things work better when connect to a powered USB hub.

  BRYNIT 09:20 21 Nov 2010

Sometimes a drive letter may not have been assigning to the drive.

Go to Control Panel/Administrative tools/Computer Management/Disk management to see if it is showing and has a drive letter.

  Quiller. 09:34 21 Nov 2010

Agree with Fruit Bat /\0/\

When using a laptop, my caddy needs the double usb lead plugged into 2 ports to work.

The laptops single usb socket does not generate enough power to work the external drive.

  morddwyd 09:54 21 Nov 2010


Tried booting with and without, tried one and both usb leads.

Not yet checked the drive letter.

Watch this space!

  morddwyd 20:57 21 Nov 2010

Checked drive letters, three allocated (three partitions).

However, as I booted up I noticed that the drive appeared in explorer, and the red access lights came on on the drive, but for something less than two seconds, then it disappeared again.

It also seems to be just the one laptop, an Acer.

The drive shows up OK on my Samsung.

  rdave13 21:23 21 Nov 2010

It sounds as it's not allocated a letter as BRYNIT suggests. With the drive connected check what drives/partitions are shown. You might have the main drive with two partitions with the DVD optical drive showing as E: perhaps. Had this happen to me on Win 7 but I use Paragon software for any hard drive maintenance. Just allocated Z as the drive letter then ok.

  morddwyd 07:52 22 Nov 2010

See my 20.57 post.

Drive letters are allocated in Disc Management - they just don't appear in Explorer.

  morddwyd 09:06 22 Nov 2010

Well, because it showed up in Disc Management I though I would try Paragon anyway.

It showed up OK, so I wiped the partitions, formatted the disc, and there it is in Explorer, large as life.

So resolved, but I don't know why!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Interview: Camille Walala on her giant 3D installation inspired by childhood funfair visits

Best iPad buying guide 2017

Où regarder le British Open 2017 ?