External hard drive

  ParkyBoy 10:24 17 Jan 2010
Locked

I have rather a strange occurence. I have had a Toshiba USB 3.5" hard drive for Christmas. I thought I would only need to plug it in and away I go. It doesn't seem that simple. I need to go into Control panel>system>device manager>hard drives, then properties to see the hard drive in my computer. I have given it a drive letter, but it still doesn't show in the drives attached. What, if anything am I doing wrong?

David

  natdoor 10:39 17 Jan 2010

Presumably it is unformatted.
Right-clicking on the drive in Windows Explorer will give you the option to format.

  User-312386 11:14 17 Jan 2010

Right click Computer>manage>disk management and then right click the drive and format.

  ParkyBoy 10:37 18 Jan 2010

Thanks a lot. Problem now resolved.



David

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

How to update iOS on iPhone or iPad

Les meilleures applications pour enfants 2017