Explorer 6 keeps closing - Windows 98SE

  splatterpuss 20:50 10 Jan 2004

Ever since I loaded some Windows upgrades and patches a few months ago, and since when Explorer has become the toll for finding and opening files instead of the previous tool, when I click on a file icon, I get an error message that tells me nothing and says that Explorer will close. It doesn't happen every time but about 50% of the time. Any ideas?

  wee eddie 22:08 10 Jan 2004

Copy it and paste it into here, so that others may read. It will almost certainly ring a bell with someone.

As your post is at the moment, no one has any idea of the cause of the problem.

The Error Message should pinpoint it!

  splatterpuss 22:30 10 Jan 2004

We Eddie - you are right. The error message said nothing but the details did. I note:
1) The same error message arises in total, regardlessof the file that I am trying to open.
2) Although it closes the Explorer being used to open files, any other explorer, for example thisone connected to the PC Advisor site, stays open.

Error message:
EXPLORER caused an invalid page fault in
module SHELL32.DLL at 017f:66801af2.
EAX=00026e35 CS=017f EIP=66801af2 EFLGS=00010216
EBX=004694c4 SS=0187 ESP=008de4a8 EBP=008de4bc
ECX=0000ffff DS=0187 ESI=66801adc FS=44cf
EDX=00509677 ES=0187 EDI=004e2844 GS=0000
Bytes at CS:EIP:
66 8b 0a 66 85 c9 75 f1 c2 04 00 83 7c 24 04 00
Stack dump:
71718675 004e2844 00000082 004e42d4 80004005 008de4d0 7171a68b 0000004b 004e2844 00000000 008de4f0 7171a6dd 00469840 004694c4 0000004b 00000000

  wee eddie 22:54 10 Jan 2004

Open Google . Paste this - the first sentence in to the query box.

"EXPLORER caused an invalid page fault in module SHELL32.DLL at 017f:66801af2"

With any luck Google should take you to one of M$'ws query pages. There you will become totally baffled but it might give you an idea of what to do.

By the time you've done that and had a go at deciphering it. Call back here - with luck others will have some ideas.

However you must beware. There is a group whose only answer is format and reinstall. While this will frequently cure the problem, you'll probably spend the rest of the week doing it, and there are usually simpler solutions to be had.

  curlylad 01:18 11 Jan 2004

Go to microsoft.com and type in the search bar Q148322 let us know if thats any help.

  splatterpuss 21:19 12 Jan 2004

Thanks guys. But none of the help has yet identified my problem. One suggests going into a clean boot troubleshoot for Windows 98 which will involve registry editing. Terrified of that.
From some of these knowledge articles, I get the impression that this is likely to be interference between a couple of programmes, so perhaps I should start removing some, one by one, but that may not help to correct the problem as it may not change the error that programme made.
I can see me heading for format and reinstall, as you said Wee Eddie. (But I know that will give me problems with the graphics card driver. I still don't know how I resolved them last time.)

  Cuddles 21:36 12 Jan 2004

Have you tried the repair option in internet explorer? MYCOMPUTER>CONTROLPANEL>ADD\REMOVE>INTERNETEXPLORER6>select repair

  woodchip 22:21 12 Jan 2004

First stop is Run SFC from the RUN box with the Win98 CD in. Second as above run the IE repair tool, by Control Panel/Add Remove/Double Click on Microsoft Internet Explorer

  wee eddie 23:04 12 Jan 2004

it makes sense if you have a Win 98 disk.

  splatterpuss 20:43 15 Jan 2004

I did try the repair tool. On reboot, Norton identified errors, which I told it not to fix as I assumed the repair kit had caused them. The problem still existed. I then let Norton fix the errors. I'll have a go at SFC now. Sorry I am so long getting back to you. The internet connection has been very bad the last couple of nights.

  splatterpuss 21:28 15 Jan 2004

Ran SFC. It identified 3 corrupt files.that I replaced from the CD. But it didn't solve the problem.

As the CD is Windows 98 SE, I don't know what the latest files it will have on it are. The files replaced were capi20.dll, capi2032.dll, and setupx.dll. I don't know what they do. Strangely, before I replaced them, I ignored the replacement request and ran the report which said that the new capi files were '97 whereas the previous ones were 23/04/99. So I assume this means that some program that I have installed has overwritten them with older versions. I will try to find the version dates on the CD in a minute.

I looked at the rest of the report, and there are many files that are older than the ones they replaced. Should I try and find the newer versions of all of them? Can that be done easily?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

Political cartoons in 2017: Chris Riddell, Rebecca Hendin and Dave Brown on what it’s like to…

The best iPhone for 2017

Tennis : comment regarder la finale de la Coupe Davis 2017 ?