Excel problem message

  palinka 14:45 28 Dec 2007
Locked

WE do our household accounts in Excel (2000, I think)and have several files relating to these accounts.
Opening one of the files produces a message about macros – "....always safe to disable, but…....might lose some functionality…..etc."
We have never created a macro in this file or in any of the others.
Why does the program think there are macros in this file? and How can we stop this message appearing?
It appears only with one file, not with the others, yet commonsense tells us that all the files have similar characteristics.

  Simsy 15:16 28 Dec 2007

started to create a macro...

Open the VB editor, by pressing Alt and F11

In the window that opens, look in the "Project Explorer" box that is normally on the left hand side. (If you can't see it choose "View>Project Explorer").

See if there is a "Modules" folder for the Worksheet concerned. If so, and you are SURE that you dont want/need any macros in this file, expand the folder and delete any contents by right clicking and choosing "Remove" When there are no modukles left the "folder" should disappear.

This should mean that you don't get the message.

I'd recommend making a copy of the file first in case you discover that there is something in there that you need, and hadn't realised. Some automatic formating for example?

Good luck,

Regards,

Simsy

  VoG II 15:22 28 Dec 2007

Other thing to try: right click each tab and select View Code.

  Gongoozler 15:22 28 Dec 2007

If you have macro security (Tools - Options - Security - Macro Security) set to low you will never get a macro warning. I frequently use macros in the form of "Sort" buttons and so have Macro Security set to low. You only need to worry about macros if you a likely to get an infected spreadsheet as an email attachment. Open the spreadsheet that gives the macro warning, click on Tools - Macro, and see if there are any listed.

  palinka 15:28 28 Dec 2007

thanks everyone; we should be able to fix it now.

  palinka 17:11 28 Dec 2007

Gongoozler's suggestion has done the trick. For the benefit of anyone else following this thread it's Tools>Macro>Security to reach the place to set security at Low (or otherwise). Thanks Gongoozler.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

HP’s new Surface Pro rival is designed specifically for Adobe-using designers and artists

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?