Ethernet Controller Driver needed.

  theons100 18:54 24 Apr 2007

Hi everyone.

Am trying to install a Netgear Router and have found that my Network Controller is not installed properly and in device manager it has the dreaded yellow question mark!!

I have tried uninstalling it and then re-starting it but Windows XP says it cannot find the relevant drivers. I think this is stopping my Ethernetconnection from working correctly. Not having internet access(other than work) means I am unable to let windows search online for the relevant drivers! Where can I get these drivers from? My PC is an Advent T9206 and I do not have an installation CD as it already came with Win XP Media Centre. I have since formatted my HD and installed a different copy of Win XP Pro.

Please help cos I have been without internet access at home now for about three months (waiting for Sky to get their ass in gear!!)

Thanx in advance.

  howard64 19:06 24 Apr 2007

whilest at work download the software from netgear then stick it on a flash drive pen or similar and take it home. When I got my netgear router the cd that came with it did not work correctly and I had to download the software.

  MAJ 19:11 24 Apr 2007

What is the make and model of the motherboard, theons100? Use SIW click here to find out.

  MAJ 19:18 24 Apr 2007

XP should have the drivers, try right-clicking on the connection in Control Panel > Network Connections and from the menu choose 'Enable'.

  Eric10 19:34 24 Apr 2007

From what I can glean from the Internet your PC probably uses an MSI motherboard that isn't listed on the MSI site since it is manufactured specifically for Advent. In the absence of a diver for the onboard network card you may be best advised to purchase a discrete network card from somewhere like PC World which will fit in a spare PCI slot and will come with a driver CD. This will cost less than £10.

  ashdav 20:23 24 Apr 2007

download and run this click here
Look under networking when the results come up and see what is listed under ethernet.
You should be able to download some drivers from whoever makes the chipset.

  Legslip 09:17 28 Sep 2007

Last night I spent four hours reformatting one of my two laptops (Evesham). All went well until I tried to set up a wireless connection to my ADSL router. The laptop has on-board wireless. After a while trying, I found that in System Devices something called a Network Controller had a ? against it. I presume that this is what is stopping me getting the on-board wireless active. I have downloaded all the drivers from the driver CD that came with the laptop. Can someone get me out of jail please?

  howard64 14:57 02 Oct 2007

Legslip start your own subject dont join in on someone elses also put it in network rather than helproom

  Ashrich 16:47 02 Oct 2007

The driver you want is for a VIA Rhine III VT6105 Lan ( onboard ) you can download it from The Tech Guys , I'll try to put the URL here , but it is a long one and may not post correctly here={e60698b8-65a1-4dad-8780-97bd604dcc07}&CatID={46f5c715-d522-4e3a-a503-38156c45232f}


  Ashrich 16:48 02 Oct 2007

Nah , didn't think it would post right , never mind , you have the hardware name , and the web site , have a look at The Tech Guys , I found it in about three minutes .


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

The Evil Within 2 review-in-progress

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Camera tips to take better iPhone photos

Les meilleures applications de covoiturage 2017