Ethernet connection - 2nd PC very slow

  First Bass 22:35 15 Nov 2008
Locked

I am running a home LAN using Ethernet connections as the PCs are close together and can share my broadband Hub without needing to go Wireless. The problem is, while PC1 has a good broadband connection and runs well, PC2 runs unbelievably slow when connected to my broadband. Any ideas why this is, or how to improve the second PC's (broadband) speed? Thanks!

  mgmcc 23:36 15 Nov 2008

How does PC2 perform if it is the *ONLY* computer plugged into the router? If still very slow, there could be a hardware problem with its ethernet adapter.

  First Bass 02:12 16 Nov 2008

Thanks. When PC2 is the only computer plugged into the router it still runs at a snail's pace. The PC works fine when the connection is disabled. I added the ethernet card to this PC - it is a Realtek RTL8139/810x Family Fast Ethernet NIC. The PC is a Compaq with an Intel P3, and has a maximum allowance of 500MB RAM and runs at 797MHz. OS is Windows XP (pro) SP2. Could the card be faulty? It does access the net, but as I said, the speed is dreadful.

  ambra4 04:03 16 Nov 2008

Check that the lan card is set to Auto Negotiation and not 10Mbps

Setting – Network Connection – Right Click Local Area Connection – Properties – at the top of display

the lan card would be display - Click the Configure Button – Click Advanced Tab – Connection Type

Auto Negotiation is selected – Click OK

  First Bass 05:12 16 Nov 2008

Thanks for the posting ambra4. When I open the LAN Properties, the options under the Configure Advanced Tab are Properties Link Down Power Saving, Link Speed/Duplex Mode, Network Address, Optimal Performance, Receive Buffer Size, and 3 Wake Up settings, on ARP/Ping,Link Change and using APM mode, and then various associated values (eg enable or disable).

I enabled Link down Power Saving, and selected Link Speed/Duplex Mode which offers the Auto Negotiation Value, and I have selected this. PC2 now works faster while connected, some internet access is still slow, but this is a MASSIVE improvement! Thank you for taking the trouble to reply.

  ambra4 06:27 16 Nov 2008

Glad to here that your Internet connect speed have improved would also suggest that you update the driver

click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Add Depth Of Field to a photo using Tilt Shift Blur in Photoshop

iPhone tips & tricks

Les meilleures tablettes 2017