Error -RTHDCPL.EXE – Illegal System DLL Relocation

  bmori 12:13 05 Apr 2007
Locked

I now get an error on my pc after a recent windows XP update.

At start up this message pops up

RTHDCPL.EXE – Illegal System DLL Relocation

The system DLL user32.dll was relocated in memory. The application will not run properly. The rRelocation occurred because the DLL C:\WINDOWS\system32\HHCTRL.OCX occupied an address range reserve for Windows system DLLs. The vendor supplying the DLL should be contacted for a new DLL

I did a system restore to a few days ago and the error disappeared for a day - presumably windows updted again!

Anyone have any idea how best to get rid of the error ?

bill

  VoG II 12:20 05 Apr 2007
  Whaty 12:23 05 Apr 2007

This is due to a recent windows update and is quite easy to sort out.

Go to add/remove programs, look for security update KB925902 installed on the 4/4/07. Select it and then select the link 'click here for support information', then select the 'Support Information' link.

This will descibe the problem you have and from here you will be able download the 'hotfix' KB935448.

This should do the job..

Regards,
Terry

  Whaty 12:25 05 Apr 2007

VoG™ beat me to it.... again!! :-)

  bmori 13:25 05 Apr 2007

thanks guys - fix worked for me - you've saved me a heap of time searching microsoft!

  GroupFC 13:46 05 Apr 2007

The heading of this was beyond me - but having a few idle minutes I thought I would have a quick look.

Now I am glad I did because funnily enough I had a very similar message last night at home when trying to run Tugzip! Now I know what to do to fix it!

Thank you.

  ukthesis 15:22 05 Apr 2007

It isn't resolved. Neither the program that you download from Microsoft (that I ran yesterday - without any effect) of removing the 4 May 2007 security update that seems to have caused the problem (through Control Panel and Add/Remove Programs) has removed it. It was here, after I did this, today. I think the basic problem is that when I restart the PC, XP automatically re-installs the security item that's causing the trouble. How does one remove it, when it's installed automatically ??

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

50 best online Adobe XD tutorials

iPad Pro 10.5in (2017) review

Comment connecter un MacBook à une TV ?