Error message on start up

  Mumcookie 20:13 19 Sep 2007
Locked

Can anyone help me get rid of a message I get everythine I start up my PC. The message is "The procedure entry point apsGetInterfaceCount could not be located in the dynamic link library wlanapi.dll"
It start after my Son had been trying to set up a wireless link from my comuter to his. He has been successful but now I get this message. It lets me close it down but annoys me everytime I start up.
Cheers

  VoG II 20:16 19 Sep 2007

Which version of Windows are you running?

  Mumcookie 20:43 19 Sep 2007

I am running Vista

  VoG II 20:48 19 Sep 2007

From what I can glean you need a Vista-compatible driver click here

  Mumcookie 20:58 19 Sep 2007

Thanks but I do not want a vista driver. I do not want to connect this device up I just want to get rid of the error message at start up

  VoG II 21:01 19 Sep 2007

Assuming that Vista has System Restore, use it to restore to a time before your son set up the network.

  Mumcookie 21:13 19 Sep 2007

won't that lose the wireless router and dongle I set up after this. My Son tried to set up something and failed and then I set up the woreless router and dongle which is not happily working. The error message is from the stuff my son tried to set up but failed and is a different item to the one we now have working.

  VoG II 21:18 19 Sep 2007

This wasn't clear from your original post. If it was me I would go back to before your son's failed attempt then set-up your wireless router and dongle again (you should be able to do this on 'auto-pilot' having done it once already).

Good luck.

  CM2007 04:22 27 Sep 2007

I would like to know if you finally found a solution.

I have the same errors messages and I don't know how to solve these problem.

The 2 messages are :

The procedure entry point apsGetInterfaceCount could not be located in the dynamic link library wlanapi.dll

The procedure entry point apsInitialize could not be located in the dynamic link library wlanapi.dll

Like you I have a Windows Vista Home and my computer is a HP desktop a6000n.

Hoping to get a solution.

  Mumcookie 18:09 27 Sep 2007

Sorry to say I have not found a solution to this. What caused the message to come up ? My son had been trying to intal a D Link airplus G wireless USB adapter. I have to admit I did not follow VOG's advice to go back to a restore point because my Son has managed to install the USB now (don't know how he ignored the instructions which were not working and went with his "gut" feelings as only a 16 year old can) and I am scared I may undo his good work. If you get an answer I would be delighted as it is soooooooooo annoying keep getting this message.

  brundle 18:23 27 Sep 2007

Click the Start button/orb and type

appwiz.cpl

directly into the search bar , press return or click Appwiz.cpl which ought to appear at the top of the start menu

Look for D-link entries relating to your hardware and uninstall the driver. If your working wireless kit is D-link you will need to check and double check the device description before clicking to make sure you are removing the problematic software, not the working one.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone