Error message - Illegal dll relocation

  Never again 09:20 05 Apr 2007
Locked

After installing todays windows update and rebooting as needed I had this error pop up:

"RTHDCPL.EXE - Illegal System DLL Relocation
The system DLL user32.dll was relocated in memory. The application will not run properly. The relocation occurred because the DLL C:\WINDOWS\system32\HHCRTL.OCX occupied an address range reserved for Windows systems DLLs. The vendor supplying the DLL should be contacted for a new DLL."

This pops up at every boot and is driving me bonkers.

I googled it and its tied in with my laptops sounf setup.

I am running windows xp home.

Any help would be appreciated please.

  Kat440 09:30 05 Apr 2007

click here This should help as the same question was asked earlier on.

Kat

  ukthesis 10:51 05 Apr 2007

No, it doesn't solve it on my PC. Downloaded it from the Microsoft website but nothing happened. I also deleted it via Control Panel, as it's a recent security update. This did get rid of it, but only for a time. Seems that each time you restart the PC, the company automatically puts it back up there as a security update. How do you stop this particular automatic update from occurring?

  EARLR 11:00 05 Apr 2007

I used Kat´s link. fixed it me.

  ukthesis 15:24 05 Apr 2007

That's the one I first used !!

  Cymro. 15:30 05 Apr 2007

This problem has come up several times over the last few days. I myself solved the problem

with help from this site. I don`t remember the address of the site that I used but I

am sure that someone more experienced than me will come up with the right site for you.

Try going back over the Helproom section of this forum for the last two days or so and

the answer to your problem is there for you if you can only find it.

  Woolwell 16:04 05 Apr 2007

Did you follow this click here

and then download and run the package.

This fixed it for me.

  Never again 21:58 07 Apr 2007

I originally searched but there were no other threads, but later noticed the fix posted by Kat440's link.

My problem is now fixed.

Thank you all for your help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Intel Coffee Lake release date and specifications

12 Amazing British Craft Beer Label Designs

watchOS 4 review

Les meilleurs navigateurs internet 2017