Error loading operating system

  Gaz_dc 19:53 09 Oct 2004
Locked

Hope someone can help.

I downloaded Fedora Core 2 from Red Hat Linux and installed it as a dual boot with windows xp. The install itself was fine, but I couldn't then boot into windows (Linux was fine). I used the recovery console from the xp setup disk to try to fix the boot record. I used fixmbr with no luck. I then used fixboot again no joy. Now I can't access anything - my PC is useless. Is there any way I can repair this and save my data or am I looking at a complete re-install?

  mgmcc 21:00 09 Oct 2004

This is a bit of a long shot but have you tried booting with a floppy with the NTLDR and NTDETECT.com files on? It should then fail to find the Boot.ini file and default to loading from C:\Windows

The two files are in a ZIP on my website click here

  Gaz_dc 22:26 09 Oct 2004

I will try it first thing in the morning and let you know.

Any other ideas anyone, incase this doesn't work?

  Gaz_dc 12:31 10 Oct 2004

I have now managed to start the boot process, but get a message saying "The file \system32\hal.dll is missing or corrupt". Is there any way to extract this file from the XP setup disk?

  Fruit Bat /\0/\ 12:44 10 Oct 2004
  Gaz_dc 13:05 10 Oct 2004

Tried that still with no luck. Expanded the dll fine, rebooted and still get the same error ("Windows could not start because the following file is missing or corrupt: <Windows root>\system32\hal.dll"). Using recovery I tried systemroot whilst in c:\windows and tried again but no joy - HELP!

  Gaz_dc 14:33 10 Oct 2004

I need help with this desperately - I don't want to have to re-install!

(I guess I should've backed up first but I have done this before loads of times with no probs - 'spose I just got over confident!)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

What is ransomware and how do I protect my PC from Petya?

Microsoft Surface Studio – the artist's hands-on review

Original iPhone review

Comment mettre à jour Kodi ?