error deleting reg key

  hugh-265156 15:22 11 May 2003
Locked

hi all ive got xp home.just noticed in eventviewer there was and error system/servicecontrolmanager "powert the system could not find the path specified"i think this was a program i installed some time back but no longer have called powertweak.i have done a search for any folders and nothing came up.had a look in the registry and found HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\LEGACY_POWERT which i think is the problem.decided to delete it and see if fixed the error message so exported first as always but on trying to delete the key i get "cannot delete LEGACY_POWERT error while deleting the key.tried renaming it and see if would let me delete it but get error cannot rename.any ideas folks?thanks.

  jazzypop 15:56 11 May 2003

you can't delete it, because the powert service is still running.

Stop the service first, then delete.

  hugh-265156 16:01 11 May 2003

forgot to say its not listed in services.

  jazzypop 16:05 11 May 2003

Reinstall powertweak, then uninstall it.

  hugh-265156 16:07 11 May 2003

will give it a go if i can find the disc ta.

  Cathode 16:45 11 May 2003

If you look in the left hand pane in the registry entry under permissions you can remove the deny tick and allow deletion.

  hugh-265156 16:50 11 May 2003

just reinstalled and nothing listed in services.so uninstalled it again.now i have four entries in the registry 3 of wich cannot cannot delete all the specified values and the original one error cannot delete.also now i have another two errors showing in event viewer that were not there before as i cleared all events before i started this one says eventsystem"COM+decteded a bad return code during its internal processing HRESULT was 8007043C from line 44 of d:\nt\com1x\src\events\tier\eventsystemobj.cpp." the other is error vss"volume shadow copy service error unexpected error calling routine cocreateinsistance.hr=0x80040206.microsoft have no help on this.

  hugh-265156 16:54 11 May 2003

thanks Cathode didnt even realise that was there but read and full control is ticked. no tick in deny box.

  hugh-265156 17:05 11 May 2003

that worked a treat just had to change permissions for each key and it let me delete after all and no error at all now in event viewer either.you learn something new every day in here my thanks to all again.

  Cathode 21:50 11 May 2003

:-)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?