Erratic behaviour PC3 on home wi-fi network

  Maineman 22:13 10 Mar 2005

Hi all, I have my main PC (PC1) running XP pro SP2 which is attached by cable to a Belkin adsl wireless modem/router. I am in the loft, and below me in a bedroom is PC2 running XP pro using a linksys wireless usb adapter. Thes two work fine together, sharing files/internet. PC3 is an older machine on ground floor running Win ME. I have installed the same linksys usb wireless adapter. I have spent hours on the phone to Belkin & Linksys! PC3 sees the router/modem but cannot connect to the internet. However, by some fluke yesterday it did connect and all was fine. Today for some reason it will not find the net again. Ip address etc and settings remain the same, have rebooted modem/router and PC1/2/3 to no avail. Can the weather affect it?? Signal etc seem to be good. It's driving me mad! Thought I'd cracked it yesterday only to find that it's back to square one today. Suggestions/tips appreciated.

  FelixTCat 23:32 10 Mar 2005

In Internet Options - Connections on PC3, have you set it to never dial a connection?

  Maineman 00:03 11 Mar 2005

Yes the connections options / LAN options are all blank/unchecked on PC3 under internet options/connections.

  FelixTCat 08:25 11 Mar 2005

Can PC3 see PC1 and PC2 in My Network Places?

Can they all ping each other successfully?

  Maineman 10:29 11 Mar 2005

No, PC 1 sees PC 2 and has access to PC2 shared folder, but PC 3 sees nothing. PC2 does not see PC1 according to shared options.
However on the Belkin IP page it shows PCs 1,2,3 as clients.
Not sure how to 'ping' each other. I know I have to 'run' 'command' and then 'ping' followed by something???

  FelixTCat 10:38 11 Mar 2005

If the Belkin is showing them all as clients then it sounds as though it may be the firewalls which are causing the problem.

Turn off the firewalls on all the computers. With XP SP2 the firewall is turned on automatically. Make sure that this is turned off as well as any third-party firewall you may have.

Check for connection to the internet (the router will protect you for a short time whilst you simply check that you can connect).

  Maineman 13:38 11 Mar 2005

The Belkin Ip page is no longer detecting PC3 in the client list...
PC3 is coming up with a Windows error message now and then saying 'the system detected a conflict for Ip address *** with the system having hardware address ***. The interface has been disabled'
The hardware address displayed relates to my wan mac address on the Belkin IP webpage... not sure what that means!
Also the Ip address, default gateway address, DNS address are all the same on the PC3 network device settings. Should that be so? DHCP is disabled and the subnet mask is correct.

  FelixTCat 13:55 11 Mar 2005

PC3 should be set to obtain an IP address and a DNS server address automatically. (So should PCs 1 and 2.) The IP address conflict makes me think that you have set the addresses manually.

Log into the router using PC1 and make sure that it is set as the DHCP server and that it will serve the correct number of IP addresses (at least 3).

Disable the wireless protection features for the time being - WEP encryption, SSID concealing and MAC address filtering - in case they are causing problems; you can always reset them later.

You must be exhausted running up and down all the stairs :)

  Maineman 14:43 11 Mar 2005

Cheers FelixTCat, saved the day! Excellent news, I appreciate the input. You were right, Linksys/Belkin help had me input manual settings to try and get it working. Now reset to auto detect and found the net straight away. The stairs are getting a beasting it's true enough! Just a thought, if I now reset my firewall / security settings will that affect anything? Try it and see I guess!
Many thanks.

  FelixTCat 18:24 11 Mar 2005

You're very welcome. Glad it all worked out.

When you set your firewalls, make sure that the IP addresses of all 3 pcs are in the Green Zone, Friends Zone or whatever your firewall calls it. I suggest you firewall one pc at a time - if it works and all 3 pcs can still communicate, then move on to the next.

Similarly with wireless network security. If you want to set it, I would suggest one step at a time, say MAC filtering, then SSID concealing, then WEP. Each time, set it up and make sure everything works before moving on to the next.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?