Epson SX515W Wireless Printer & Vista Laptop

  pip78900 23:14 30 Dec 2010


We have two laptops (mine running Windows 7) and my OH (running Vista). We recently bought a Epson SX515W wireless all in one printer. From the pre-reading we'd done we expected problems with setting up the Windows 7 laptop but was led to believe it would be a quick installation for the Vista machine.

OH followed instructions for wireless installation and printer appeared on network. I then found the printer on the network and using the drivers I'd downloaded from Epson was able to connect to the printer without any trouble.

However, some 7 hours later OH still can't connect to the printer. He can see it, but when he sends anything to print he gets the Error Code 0x00000643. He has tried uninstalling and reinstalling without success. The Microsoft help article on the subject hasn't been very helpful either.

Any advice on what we can do before the printer flies out of the window?!!!!



  pip78900 20:25 02 Feb 2011

Thanks for your response. Sorry for not coming back sooner but I have been poorly.

The OH has tried doing what was suggested in those links without success. However, when he connects his laptop to the printer via the USB cable it works fine. He now has two icons for the printer: one for USB connection (works fine) and one for wireless (which gives the error message referred to above).

Is there anything else we can try.



This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

How to find a font: Discover the name of a typeface with these apps

The best iPhone for 2017

Les meilleurs logiciels de montage vidéo gratuits (en 2017)