Epson stylus colour 600

  clayton 16:02 25 Jan 2003

Ive just installed new ink Cartridges in my printer but all i get is plain paper no print,ive tried the print haed cleaner but no joy any ideas ??

  Djohn 16:04 25 Jan 2003

Make sure you have removed the tape on the top of cartidge, and sometimes it can take two or three cleaning cycles for the 600 to pull ink through.

  clayton 16:43 25 Jan 2003

Thanks for your reply Djohn ive tried that & still no joy not a drop of ink, there are epson cartridges.

  Djohn 16:54 25 Jan 2003

clayton, was the printer working ok prior to putting new cartridges in?

With your other ones you didn't by any chance try to get more life from them by taking them out and re-inserting them?

  woodchip 16:56 25 Jan 2003

Make shure the breath holes are clear in the top of the Cartridges with a pin

  Djohn 17:10 25 Jan 2003

Good point from woodchip, to take your cartridges out you will probably need to do the following, because they are not showing up as empty.

Leave printer switched on, press ink button on front of printer and when the cartridge moves out to the centre, pull the power plug from the rear of printer.

Cartridge will now stay there, while you remove and check, as well as woodchip's advice have a look underneath to see if the little rubber covers have been pierced to let the ink out.

If not then replace them and make sure you press the retaining clip down firmly.

Replace plug into rear of printer and it will now reset itself, if this does not work, post back on this thread. J.

  peterleemaxwell 17:16 25 Jan 2003

Hi Clayton,
I had the same problem with my 600. I found that
after taking it apart and studying it there was supposed to be a plastic point that pierces
the cart entry, and it had broken when I had removed the old cart. Only a possibility.
Worth a try.

  Diemmess 17:23 25 Jan 2003

It can happen particularly if you ran the ink dry or left the printer without a cartridge in place.

When you have tried and checked everything else, then put the new cartridge/s in and then switch off.

Do something else until tomorrow, and then you may find that it works normally or an automatic single head clean will be suffient.

I think what happens is that a tiny bubbble develops in the ink channel and overnight the ink filters through to the printhead displacing the air sand allowing the piezo effect to work on incompressible ink

  toga 11:45 26 Jan 2003

Hi Clayton, sorry for jumping in but I am experiencing the same problem (as we communicate) with an aging Epson Stylus 300.

I have tried all the points that have been mentioned so fare without any luck.

My question to anyone that can help is: is it possible that when replacing the ink cartridge I have damaged the print head which holds the cartridge and if so can it be replaced?

Any replies my same what is left of my hair!

Thanks toga

  toga 11:47 26 Jan 2003

That last sentence on my reply should have read:

Any replies may save what is left of my hair - see what I mean!

  Spencus 12:25 26 Jan 2003

An Epson engineer suggested the following when I had the same problem,tap the cartridge on a hard surface as it may have an airlock

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

See the Best Button Badge Designs of 2017

iPhone X review

Black Friday 2017 : date, sites participants & bonnes affaires