Epson Stylus C80 - Still not Working

  Pesala 12:55 18 Nov 2004

Got the cleaning kit from click here Replaced the black cartridge with the cleaning cartridge. Ran through a few cleaning cycles. The cleaning fluid came through and printed grey just fine. click here Replaced the new black Jettec cartridge, which is now showing half empty. Not printing anything at all. Replaced the cyan cartridge, which was empty. Working fine, as are yellow and cyan.

Tried several pages of black only. Nothing at all coming through.

  xania 13:26 18 Nov 2004

Sounds as if the nozzles on the cartridge may be blocked. DOn't know Epson so can't advise how to resolve this, but read the manual with your printer and with your cleaner to see how to unblock the nozzles.

  Pesala 18:19 18 Nov 2004

Apparently the nozzles are not blocked as the cleaning fluid gets through fine, just no ink. Is it perhaps the inlet hole on the cartridge that is blocked? These compatible cartridges have a plastic tab that pulls off. No problem with any of the colour cartridges, which are also Jettec.

  Rayuk 18:36 18 Nov 2004

Have you tried putting the cartridge in a plastic bag and shaking it vigorously up and down

  Pesala 18:50 18 Nov 2004

I held a tissue over the outlet hole, and shook it. Where is the inlet hole on these cartridges? I have an empty cyan cartridge, and the red plastic tag one pulls off, but cannot see any hole, or how the tag fits back on.

  alB 19:26 18 Nov 2004

I have an Epson 680 and use Jettec cartridges so I'm guessing that your C80 will be similar, check that the membrane on the outlet hole has been punctured and reseal it with a piece of sticky tape, the red plastic tag should be taken off and discarded, the small piece of tag that remains in the cartridge is the breather hole, try and make this a little bigger with a needle until you can push through and feel the resistance of the sponge inside the cartridge, leave the hole open and replace in the printer, run a cleaning cycle and try and print...alB

  trevpearson 19:44 18 Nov 2004

Maybe this will help

click here


  Pesala 19:47 18 Nov 2004

click here for a picture of the cyan cartridge. I found a small red plastic hole in the top of the black cartridge near the back of the printer. I was able to push a needle into the hold about 1 cm, until it met something hard.

  Pesala 08:53 19 Nov 2004

Still stuck.

  alB 13:39 19 Nov 2004

The red plastic hole is the breather, if you can push the needle through it should be OK, did any ink come out of the outlet hole when you first took the cartridge out, I'm wondering if the cart has dried out even though it's a new one, do you have a spare you can try or can you refill this one? ...alB

  Pesala 18:07 19 Nov 2004

I was reluctant to try the cheaper premium brand black cartridge again from click here as the last one was not recognised by the printer, and that seemed to be the beginning of my problems. I changed all the cheap ones for Jettec, but the black Jettec cartridge seems to have been faulty. Still a slight line on the Magenta click here

Problem resolved, for now at least, but I am still none the wiser as to what the cause was, or which brand of compatibles to trust. Probably I don't do enough printing and the cartridges dry up.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?