Epson RX600 ink change

  Roy* 22:01 14 May 2005
Locked

Just tried changing 2 ink cartridges ('think' Epson compatible R300-RX600 from choicestationary) and it won't recognise 1 of them (yellow), it just keeps coming up with 'open the scanner unit. Replace the ink cartridge' and I've tried installing a few times now. Is it a problem with this one cartridge as the black seems to show OK and full on the graphic. Any tips please?

  roy 23:02 14 May 2005

Hi Roy,

I use 'think' Epson compatibles with my rather old Stylus Photo 700. The only trouble I had with my colour cartridge is that the printer would not pierce the membrane at the bottom of each colour. I didn't like to force it in and solved it by piercing it with a biro first.

This probably doesn't help you but will at least keep your thread near the top.
Roy

  woodchip 23:07 14 May 2005

give them a ring i would think a faulty cart as they are chiped

  Roy* 09:31 15 May 2005

I've sent Choice an email as they're office ours are 9 til 5 or something and only open Saturday morning at the weekend.

  Roy* 11:24 16 May 2005

Bought a Staples one Sunday morning for £7 and that worked fine. Twice the price of Choice but needed it to work.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Best phone camera 2017

Stunning new film posters by Hattie Stewart, Joe Cruz & more

iPad Pro 10.5in (2017) review

28 astuces pour profiter au mieux de votre iPhone