Epson R300 wont recognize inks

  TN 15:31 27 Sep 2010

I have an Epson Photo R300, which I've had for about 18 months. I have always used compatible inks with no problem. I replaced a 2 cartridges over a month ago and all was well. However yesterday I got the message that the printer did not recognize ANY of my cartridges! These have always been the same make and from the same supplier so why has the printer decided that it cannot recognize them>? I have tried un-installing the printer and re-installing it: I have taken out the cartridges and replaced them with new ones that I had in readiness but still the same result. Not that it should matter but I am running Windows 7 Pro. Has anyone (a) had this problem and (b) is there a way round it? All help sincerely appreciated. BTW I have periodically reset the protection counter so that is not the problem

  gengiscant 16:59 27 Sep 2010

I have never had all carts being rejected,just the odd 1 or 2 but these have always been exchanged without any trouble.
Perhaps an email to your usual supplier setting out your problem, I think you will find that they will exchange them.Might be just a bad lot, see what they say.

  TN 19:21 27 Sep 2010

Thanks gengiscant but that would not explain why they were all working for the last few weeks and only started not being recognized, as a group, all at once - if it were just faulty cartridges (which has never occurred before) then they would not all have been rejected at same time. I feel there is something else wrong with printer and not the cartridges. What do you think?

  northumbria61 15:46 28 Sep 2010

See here - click here

  woodchip 15:53 28 Sep 2010

May be the Printer Driver as become corrupt, Go to Control Panel Add Remove Programs uninstall Epson then Go to Start\Settings\Printer folder make sure that printer as been removed, if not right click and delete it, Next Do a Search for Epson and Delete what it finds with epson in it. Now unplug Printer Put the Printer CD in the Drive run Setup and only plug printer in when it starts looking for it

  TN 17:15 28 Sep 2010

Thanks woodchip but as I stated in my thread I had uninstalled the printer and re-installed it - my son has just pointed out that last month I completed a 'Valued Opinions' survey which was about compatible inks and was asked if I used Epson or compatible ink - I answered truthfully that I never used Epson ink - could Epson actually fiddle with the firmware in the printer???? Or am I being paranoid??? Having checked the article in the above answer I may be right.

  woodchip 19:35 28 Sep 2010

As I said its not just a case of removing Printer you have to remove everything about it from your computer before reloading software and printer, this may also mean going into regedit to search for Epson and remove them all

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Galaxy Note 8 vs iPhone X

Awful clip art from 1994 is being tweeted every hour by a bot

iPhone X vs Samsung Galaxy Note 8

Les meilleurs navigateurs internet 2017