epson R285 ink problem

  roywoodcock 18:53 28 Feb 2009
Locked

I recently changed the black ink cartridge on my epson R285 , but it did not charge , afterwards it told me all the inks needed changing , as they were not compatible , it worked fine before this although Im not using epson ink , can anyone help ?

  m800afc 19:17 28 Feb 2009

Sory I am not able to help as such, but have a look at my thread.

click here

  richierich 21:43 02 Mar 2009

Ive had exactly the same prob with my 285 a couple of times , here is what i did to resolve it. turn off printer, disconnect from mains (switching off is not enough), leave for a couple of minutes then reinstall cartridges. It worked for me.
Although now i have invested in a continous ink system which has worked flawlessly for months and is dirt cheap to run.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?