Epson C86 Ink Problem

  spuds 14:12 24 Jul 2006
Locked

I have used an Epson Stylus C86 printer for quite a while now. Never had any problems with using this printer or printer compatible cartridges.

Over the weekend, the magenta and black ran out, so I replaced both. For some unknown reason, the magenta doesn't want to seem to work. Replaced the magenta compatible cartridge for another manufacturers make, but still no success. Have done the usual Head Cleaning a number of times, but this cleans all cartridges, with the result that the printer is consuming vast amounts of ink in the process.

Can you provide an answer, so that I can get the Magenta to work. All the other cartridges and colours, Black,Cyan and Yellow all appear to work fine.Without magenta the print-outs can turn out terrible.

  johndrew 14:17 24 Jul 2006

You could look here for help click here they provide all sorts of information that may not be available in a general forum.

  spuds 14:37 24 Jul 2006

johndrew-- Thanks for the link, which I have used and recommended to others in the past. Been to it this time, and it would appear that Epson send out a replacement printer (if in warranty?)due to the print heads being clogged.

Epson give a number of possible solutions, like using only Epson ink cartridges, not turning off the printer, do regular head cleaning exercises. Which I suppose, is the easy way out!.

Some people have just binned the printer, but it would be a real shame to do this, with a printer just over twelve months old(?) that was working perfectly before the magenta ink ran out at the weekend.

  johndrew 16:52 24 Jul 2006

Might sound daft, but my printer can take an age to re-prime if the cartridge is really empty when I replace it. I also used the SSC utility click here to aid on the contents.

Any help?

  spuds 19:32 24 Jul 2006

Just downloaded and installed SCC. How do you use the 'Separate cleaning of colour and black heads for all Epson inkjet printers, powerful cleaning mode' tool device?.

  johndrew 19:42 24 Jul 2006

If you start it you should get the icon in the right hand toolbar. Right click and all the options are there. I suggest you start with `Initial Charge` and then go to the `Power Clean` and finally do a `Pattern Check`. You may need to repeat the `Initial charge` a couple of times.

  johndrew 19:44 24 Jul 2006

Sorry forgot. There is `Help` in the same menu.

Hope it works for you.

  BT 08:12 25 Jul 2006

I had a similar problem with my C62 recently. The colour cartridge would suddenly show empty even though it was almost new,and even installing another cartridge didn't cure it.
In desperation and after trying everything else including new drivers etc., I changed the printer lead. I have always used a parallel lead so I installed a USB lead instead. Result no more problems!

  spuds 15:20 25 Jul 2006

Back again after a little experimenting. Tried the 'Initial charge' and it appears to work, but for how long!. So going to carry on experimenting and report back later. Thanks once again to johndrew, for their suggestion and advice.

BT-- I have always used a usb cable, as I found that it the best if connections are available. After trying out SSC, I would recommend that product, seems to work very well.

  johndrew 16:47 25 Jul 2006

`.... seems to work very well.`

I like it. It has some good facilities. Pity it doesn`t work with other printers.

  David4637 13:47 26 Jul 2006

On Canon printers you can remove all the good carts, and deep clean only the ones that are not working properly. Have you tried removing the good carts on your Epsom? David

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?