Epson C66

  jim63 09:41 26 Oct 2007
Locked

Help. Just cleaned print heads and now get 2 flashing red lights ink and paper feed ones. Have disconnected power and usb. waited and then reconnected but still same problem.

  spuds 09:51 26 Oct 2007

Sound like you have a typical Epson waste ink tank problem, if the fault is not damaged print heads.

How did you clean the heads?.

  jim63 10:19 26 Oct 2007

Used printers own clean.had removed blue cart after clean and then installed,thats when problem started. Have ssc service utility but not sure how to use that.

  spuds 10:42 26 Oct 2007

Are you using Epson own brand cartridges or compatibles?.

The SSC Service Utility is a very good device, because it can do certain things that Epson cleaning-maintenance method doe's not allow.

In this particular case, it could be the printer doesn't recognise the cartridge after re-install, and it might need re-setting.

Try this:Go to SSCS and enabled it to your printer, then do a purge clean. Be careful when doing this, as it uses quite a bit more ink than a normal clean.

You could also seek further advice from click here

  Pamy 11:07 26 Oct 2007

What happend about Thursdays post? click here

  jim63 11:56 26 Oct 2007

Pamy. Still not sure about taking out waste ink pads

  jim63 12:30 26 Oct 2007

""Tried this thread which I found for Canon Printer and it has worked for Epson. Hope this might be of help to someone else.""
1) Power off printer
2) Hold RESUME button then press and hold POWER.
3) Hold POWER and Release RESUME.
4) Press RESUME twice then release both POWER and RESUME buttons.
5) When the indicator lights steady, press RESUME
6) Press power to set data.
7) Print

Failing that possible solutions could be found here:
click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

These brilliant Lego posters show just what children's imaginations are capable of

Mac power user tips and hidden tricks

Comment réinitialiser votre PC, ordinateur portable ou tablette Windows ?