Epson C60 will not install

  Mick54 15:02 07 Mar 2009
Locked

Hello pps, I have a pentium 4 running at 2.4Ghz, 768 mb ram, Windows Xp prof, sp2, using firefox. I had the Epson C60 install on this pc but I upgraded to an Epson R285. I uninstalled the C60. I now want to re install the C60 as well as using the R285 but the hardware installer finds the C60 but fails to install it saying invalid printer name. The add printer option does the same thing. Both the printers are connected with a usb. I tried swapping the C60 to a parrallel port but did not work. When using the add printer it fails to find it even thou if I switch the printer off and on again the hardware installer does find it but will not install it. I used the proper disk to download the drivers but no luck. Do I need to unplug the R285 first for the pc to install the C60? Have tried many options but I am stuck. Can you help please? Thanks Mick.

  Fruit Bat /\0/\ 16:34 07 Mar 2009

Do I need to unplug the R285 first for the pc to install the C60?

Yes

Also plug direct to a main USB port and not through a hub.

  Mick54 17:44 07 Mar 2009

Hello pps, I dont know quite what I did to resolve this but as far as I remember the sequence, I changed the install name to Epson Stylus Photo EX3 ESC\P2 in the pull down list on manaul install when the Hardware installer failed. The install took place and I checked the box to print a test page not expecting it to work but it did. I then renamed the printer to Epson C60 but it still uses the Stylus Photo EX3 drivers. I will keep my fingers crossed. Thanks for the suggestion Fruit Bat, I may need it later. Ta Mick.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

HP’s new Surface Pro rival is designed specifically for Adobe-using designers and artists

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?