Epson C48 installation problems

  justjill 18:21 17 Mar 2006

After a bad experience last week with a printer I bought from Ebay which turned out to be faulty, I decided to save any more hassle and buy a new printer. I decided on the Epson C48 from Maplin. It arrived today so I uninstalled the old printers and installed the new one, following the instructions carefully as I always do, but I have a number of problems:

1. The cartridge holders should have moved into position for cartridge installation automatically but they didn't. I followed the instructions which said to press the printers red ink button but I had to do this about 8 times to get it in place - there was no mention of multiple pressings of the red button. Does this mean there's a problem with the printer?

2. When I installed the ink cartridges I got a "non-genuine ink warning" - infuriating because these are the Epson cartridges that came with the printer. Grrr!

3. I can't print anything. The PC can see the printer but it just won't print and I don't get any error messages. I've tried fiddling about with ports as I had to do to get the last printer working (inasmuch as it worked - grrr!) but the Properties dialog box continually stops responding.

The only reason I can think of to explain any of this is that I had to install a USB to parallel printer converter cable with the last printer but I can't now find it to uninstall it - could this be the problem and if so, how can I fix it?

I'm really annoyed about this. It's not as if I'm a thick computer newbie - I'm highly computer literate (for a girl), I've designed several websites for friends and local businesses, I've upgraded computers several times (yes, taken the back off and everything), solved software and hardware conflicts for myself and other people and yet lately I can't install a poxy printer! What's going on? I had no such problems in the days of Windows 98! And why do these things always happen on a Friday evening when the helplines are closed?

Anyway, I digress. Any help with the printer problem would be greatly appreciated.

Many thanks,

  woodchip 18:29 17 Mar 2006

Have you removed all the tapes that restrain printer mecanisam from moving and the tapes on Printer cartss so ink gets out and air in? also try a pin in the top of the carts where you removed the tap. then got ot Start\settings\printers right click your printer\Properties\print test page

  justjill 18:41 17 Mar 2006

There was only one tape and a sheet of protective plastic on the printer (not the 4 tapes there were supposed to be) and I've removed those, and I've taken the yellow tapes off the cartridges. I would try your tip with the pin but I can't now get the cartrige holder into a position where I can take the cartridges out. Pressing the red ink button is supposed to do it but it just moves out of it's hiding place, takes in some paper and then goes back to it's hiding place.

I tried to print a test page earlier and it just held it in the queue and reported no error message. Now when I try to do it the dialog box stops responding and closing it causes explorer to close.

  woodchip 18:48 17 Mar 2006

Looks more and More like a faulty Printer

  woodchip 18:58 17 Mar 2006

Was your old Printer a Epson?

Whatever Printer you had, Try this. First unplug the Printer, Remove Printer from Add Remove and any other printer while you are doing this, Next do a search for any printers one at a time like Epson Delete all it finds.


Go to Start\Run type REGEDIT in regedit click the computer Icon at the top in case the tree is open, next go to Edit in Menu, type Epson press enter delet what it finds then press F3 to go to next untill you get to end of regedit. close regedit. if you have other printer that you removed do the same for these. then restart computer, follow epson instructions for printer setup

  namtas 19:06 17 Mar 2006

Pulled this info from a Epson help page

If your cartridge contains a printer chip and is not working after having tried the above then there is either a problem with the chip or a software conflict. If you have touched the contacts on the chip (even slightly) the cartridge will not work. If you have not then switch off your PC and re-install the cartridges just into the printer without using the software installation routine. In most instances this will sort the problem that arises from inconsistencies in the Epson printer driver software.

  justjill 19:24 17 Mar 2006

Woodchip, I'll try that after I've put the baby to bed.

Namtas, I was paranoid about touching the contacts so I was extremely careful. How do I go about reinstalling the cartridges when the cartridge holder won't move into position?

Thanks again.

  woodchip 19:29 17 Mar 2006

If the above does not work, take take the printer back

  Hertz Van Rentyl 20:33 17 Mar 2006

When the heads move when you press the red button, pull the power cable out when carts are exposed.

  justjill 21:53 17 Mar 2006

Uninstalling all printers and their associated programs and reinstalling the new printer worked! A shame, in a way, as I was so convinced it wouldn't work that I promised to eat my own hair if it did.

Seriously, though, it's such a relief that it's working now. Many, many thanks. I don't know what I'd do without you :)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

See mcbess's iconic style animated for Mercedes-Benz

iPhone X news: Release date, price, new features & specs

Black Friday 2017 : date, sites participants & bonnes affaires