Epson- black ink not working

  algernonymous 13:08 19 Apr 2006
Locked

Can anyone tell me why the black ink isn't printing on my Epson 670? I have owned it for about 5 years now and had no problems until I used a new cartridge from the latest batch I had ordered from Choice (who I have always used and been very happy with). They are 'compatible' carts, which, once again, I have always used. I have tried two of them but with no luck. The display shows them as full.

  Genius1 13:13 19 Apr 2006

I know that this sounds really stupid - it is not meant to be patronising. Have you made sure that they are in the right way round and the plastic covering on the nozzel and contact has been taken off? I'm sure you have but just in case you haven't!...

  jammin 13:17 19 Apr 2006

have you tried the head cleaning/nozzle cleaning utility?

  Genius1 13:18 19 Apr 2006

I was going to suggest this, but with them being brand new cartridges, would this need to be done? I have often wondered this.

  algernonymous 13:33 19 Apr 2006

Its the right way round and there's no plastic to be removed ( it just gets pierced) but thanks for responding- it made me look and I thought I may as well try a third cartridge- and that works!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?