Entry point not found - problems loading programs

  Nuss 18:58 14 Dec 2005

It would be much appreciated if you could shed any light on the following error messages I’ve been receiving whilst trying to download software ( Windows XP Pro. SP2 ):

Setup.EXE - entry point not found.
the procedure entry point ………could not be located in the dynamic link library kernel32.dll’

Diskstart.EXE - entry point not found.
the procedure entry point ………could not be located in the dynamic link library kernel32.dll'

Launcher.EXE - entry point not found.
the procedure entry point ………could not be located in the dynamic link library kernel32.dll'

The main piece of software I've been trying to install is the Pinnacle Studio Media Suite OEM edition (version 1.0.7 ) which came with a Toshiba DVD writer I bought. It does say on the disc itself that it is for Windows 2000 / XP.

When I bought the DVD writer I had Windows 98 installed on a previous hard drive. I did try to load the Pinnacle software to that - but got the error message that the Windows system I had was inadequate and that I needed to upgrade.

That hard drive subsequently failed and I bought a new Seagate drive and installed XP.

Initially the software loaded but there was a problem accessing the CD writing part of the suite ( it also features photo software etc ). So after registering the product with Pinnacle I engaged in dialogue with them. They advised me to remove the software and download a registry cleaner to remove any last traces , and then to reinstall it.

It was at this point that I started to get the current error messages. The disc would not load automatically nor would it load by going into 'my computer' add/remove programs function. They suggested that I copy the lot to the hard drive - which I managed to do ( after a few false starts ) using Windows Explorer. However it still would not load up.

Pinnacle asked me to provide them with proof of purchase by sending a photo of the software disc and the receipt to verify that the software is the genuine article. It was at this point that I tried to download software that came with the Olympus camera which had worked perfectly well on the old W98 system and which , according to the literature that came with it , should also work on XP ( Olympus Master software created in 2004 ).

However the same problem occurred with this software - so I have no way of sending proof to Pinnacle!

It has also occurred when I've tried to download cover discs from a couple of computer mags.

So that's the story to date. would be very grateful if you could suggest anything! What confuses me is that ( according to the research I've done on the net ) kernell32.dll file is linked to earlier versions of Windows.

Thanks in anticipation!


  VoG II 19:04 14 Dec 2005

Try running the System File Checker click here

  Nuss 19:15 14 Dec 2005

many thanks for that quick response! I work nights so have to get some sleep now but will run tomorrow and let you know what happens.
Cheers, Jules

  Nuss 18:56 15 Dec 2005

Confused! All that seems to happen when I type sfc /scannow in the run box is that I get a window that opens up 'Local Disc C' . I scanned for all files and sfc / scannow wasn't detected.
Is this a file that is supposed to be there or ( which I presumed ) something I have to download?
Also unchecked all ' hide protected operating system files' under tools as suggested but got no indication that there was anything wrong!


  beeuuem 19:25 15 Dec 2005

This is usually a version conflict between the dll in the System32 folder and the dll cache folder located within the System32 folder.

The dll versions in both folders must be the same.
Try copying all dll's from the System32 folder to the dll cache folder and allowing any changes.

  Nuss 20:22 15 Dec 2005

Hi beeuuem,
I've looked in the System 32 folder and there doesn't seem to be a cache of dll files - just a smattering of these files - is that not how it should be?!

  VoG II 20:29 15 Dec 2005

C:\windows\system32\dllcache is a hidden folder.

In Windows Explorer Select the Tools menu and click Folder Options. Select the View Tab.

Under the Hidden files and folders heading select "Show hidden files and folders".

Uncheck the "Hide protected operating system files (recommended)" option.

Uncheck the "Hide file extensions for known file types" option.

Click Yes to confirm. Click OK.

  Nuss 20:55 15 Dec 2005

Ok - will give it a go tomorrow - got to get to bed - work in a couple of hours! Will get back.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Xiaomi Mi Mix 2 review

What went wrong at the Designs of the Year 2017

iPhone X news: Release date, price, new features & specs

Comment utiliser Live Photos ?