Encryption Disabled when trying to connect

  GoingGrey 19:20 26 Feb 2006
Locked

I have a Draytek Vigor 2800 ADSL to which I have connected my desktop.

I want a wireless connection to my laptop which came supplied with a Broadcom adaptor card.

Approx 50% of the time when I try to connect I get the message in the Network connections window Encryption Disabled followed by the message Limited or no Connectivity in the Wireless Network window.

I have reflashed the Vigor with the latested firmware to fix an ADSL problem.

Also installed latest drivers for the Broadcom adaptor.

Security on the Vigor has been set to WPA/PSK.

I have set up a prefered network on the laptop to use WPA-PSK and Data Encryption TKIP.

The Authentication window for this prefered network is grey - no input allowed - assume due to the encryption choosen on the Association tab.

I am new to Wireless so dont know exactly what to expect but a 50% failure rate to connect doesnt strike me as good. Signal strenght is Very Good.

Encryption is there to help keep you as secure as poss so when as the Laptop trys to connect and I get Encryption disabled is it broadcasting the Network key without any security?

I have checked th DHCP server on the Vigor and it is set to Enabled.

HP the laptop manufacturer has suggested I need to repair the Windows Operating System - which sounds a bit drastic and scary to me?

Hope someone can think trying something else before I do this.

  keewaa 20:03 26 Feb 2006

If you turn off all security on the Draytek, does it work OK? If you use WEP instead of WPA, does it work OK? If you could check these out then it would narrow the problem down to WPA alone.

  GoingGrey 21:20 26 Feb 2006

Thanks for response

With Security disabled the laptop connects.

With Security set at WEP, the network windows on the laptop showed Encryption enabled, but it did not connect, giving by now the all familar Limited or no connectivity.

It couldnt seem to find the network address and gave the following IP 169.254.

Look forward to hearing from you.

  GoingGrey 22:05 26 Feb 2006

Just tried using WEP again and got connected.
(Although previuosly didnt, albeit encryption was enabled)

Tried WPA again and same problem. Sometimes connects and sometimes says encryption disabled and then no connection.

Connects no problem when security is disabled on the router

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?