Email footers question

  HighTower 11:36 18 Feb 2009
Locked

I was torn between posting this in Web Design or Helproom. I *!@:ed a coin, so Web Design it is!

A customer of mine asked me to create a jpeg for them that could be used in an email footer along with their contact details. I did this and send instructions as to how to impliment this in Outlook Express.

I use a Mac so the instructions were sourced from the web, but seemed to work fine as the emails I subsequently received from my customer had the footer in there just as we intended.

However, there is a strange situation where if a recipient of one of these emails replies then the image in the footer (which is positioned in the bottom left of the message) now appears in the default top left and tiles to fill the screen, making the email look awful.

I think that this may only be a problem on the one computer but I'm not sure what to suggest in order to rectify it.

Outgoing mails are fine, it's when they are replied to that they look odd. I'm guessing it's a stationery stylesheet issue. The code for the stationery is as follows:

HTML>
HEAD>
STYLE>
BODY {
font-family: Arial;
font-size: 10pt;
color: 000000;
margin-left: 25 px;
margin-top: 25 px;
background-position: bottom left;
background-repeat: no-repeat;
}
/STYLE>
/HEAD>
BODY background="email_footerO&Bf.jpg">
/BODY>
/HTML>

Apparently, the stationery tiles when viewing in sent items too. The css looks simple enough to me, anyone any ideas?

Thanks all.

  HighTower 11:37 18 Feb 2009

Seems like you can't even throw a coin in the air these days without being censored!

  Kemistri 19:07 18 Feb 2009

Curious. Is that CSS copied verbatim? Apart from the dropped angle brackets, I mean. It's just that you missed the hash in your colour declaration.

As for the question/problem, I'm not 100% sure about this because I don't create HTML e-mails and you're into a different kind of bug testing when browsers are not involved. But you might try moving your image declaration out of its inline position and into the <style> tags.

  Kemistri 19:08 18 Feb 2009

BTW: I don't know why, but angle brackets should appear OK here if you type them in by hand, but tend to go AWOL if pasted.

  HighTower 19:50 18 Feb 2009

I never noticed the lack of angle brackets in the post, but they are correct in the HTML file. There isn't a hash in the colour declaration, and this is copied straight out of the Outlook Express template file, the code being generated by the software.

I'll try your suggestion on moving the image declaration.

  Kemistri 19:56 18 Feb 2009

Put the hash in as well. It won't be valid CSS without it and that may possibly be either a contributor or the cause, depending on the e-mail client that receives it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

Best of the Grad Shows 2017: University of the West of England (UWE)

Best value Mac: Which is the best £1249 Mac to buy

Les meilleures GoPro 2017