EAccess Violation for Realtek High Def Audio

  JonJW 17:23 14 Dec 2008

Has anybody had a problem with the Realtek high definition audio error message EAccessViolation that appears on startup or when you try to access the Realtek HD control panel. The sound card seems to be working OK. Motherboard is an ASUS P5N-D. I've loaded new drivers, no go, and then loaded up the originals from the ASUS disk but still the error occurs. I've also tried the registry cleaner that came with the latest magazine, but that didn't find anything.

  The Brigadier 17:49 14 Dec 2008

Operating System info, please?

  JonJW 21:48 14 Dec 2008

Windows XP Home SP3

  Stuartli 08:55 15 Dec 2008
  JonJW 22:27 16 Dec 2008

I tried to download the updates suggested in the linked article however it says I have the latest updates.... i.e I am running SP3. Have updated everything I can find. Any further suggestions?

  paulgeaf 20:11 26 Jan 2009

Did you fix it?
Can we have an update on wehat happened here?
I am just curious cos' I have had this problem myself for a while and have tried uninstalling and installing all different versions of the realtek drivers but still the same thing!

  CurlyWhirly 23:20 27 Jan 2009

I didn't get that error but when I first bought this Vista PC I had trouble with the sound when I fitted a Creative SB X-Fi sound card and this was because the onboard sound was still enabled in the BIOS.

Like your system the onboard sound on my motherboard is Realtek.

I solved my problems by disabling the onboard sound in the BIOS.

If you have already done this then I don't know what else to suggest.

All I get now under 'Sound, video and game controllers' is the single entry for the Creative driver (below)

click here

Before I had a Realtek High Definition Audio driver in there as well.

  paulgeaf 00:42 28 Jan 2009

Hmm. thanks for that. Ii did also try installing an old creative audigy cos' I wanted the midi port(!!) and it worked fine, installed rivers and a control panel of sorts, all working fine.
The realtek one was disabled it seems, automatically because I added my own.
However I like the sound from the realtek and there seems to be no combination of uninstall, reinstall etc different versions from years ago to the present day...uninstalling with revoUninstaller doesn't help either and I am tird of it now.
No matter what I do I cannot get the realtek Sound control panel to come up...you know the one with all the effects etc and the mic boost option, also the detection setup for the different audio jacks. As I cannot access this program I can only use it as the sound comes out. Which is fine but I want the microphone boost!!
It is this very control panel that is crashing every time I boot the PC. The EAccess Violation is caused by the autostarting entry 'RTHDCPL.EXE' which is just unable to run. In the same direct as that file is another one, similarly named 'RTCPL.EXE' - I assume it is the non HD audio control panel maybe. Anyway that won't run either.
I hate it!
Not many problems get me to a dead end but I don't know what else to try.
Also, this happened on my last installed XP too. So even if I was mad enough to install XP from scratch just because of this (which I won't!) then it isn't a guarantee anyway. I wonder what it is that is conflicting with it.
That is my theory...a conflict with something or some program.
Any ideas mate?

  CurlyWhirly 20:36 28 Jan 2009

Well as far as I know having onboard sound ALWAYS conflicts with a dedicated sound card.

Before I disabled the onboard sound, I used to get a clicking noise coming from the speakers after there was a period of quietness and this crackling was loud and at one time frightened me half to death as I didn't expect it!

Since disabling the onboard sound, I no longer get any problems.

I don't know what to suggest apart from checking in Device Manager for any conflicts?


  CurlyWhirly 20:39 28 Jan 2009

p.s. I did some googling and got click here

Any help?

  paulgeaf 23:17 29 Jan 2009

Thanks for stepping to help out..two minds are always better than one right.
The link - Seemed promising at first but I would never join up to something that looks like it is asking for cash...to give help and advice privately. I mean what other reason could that site have for not just posting the 'help' they gave to all the people they have claimed they helped on the page eh?
But reading through, it seems others have had the same problem and there's no shortage of people who have trouble with this ********** Realtek sound manager or whatever you call it.
So for now I have no separate sound card. Removed the creative one totally from the system and removed all reg entries etc by hours of searching and using revoUninstaller to help eradicate al things Creative from the system.
So now it is fully reliant on the Realtek HD but it still throws the same error AND, if I try to run the sound manager exe it either throws the exact same error or it just doesn't run. I see it briefly in task manager for a second and gthen its gone.
I will have to keep searching.
I REFUSE to let this beat me!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 Hack Latest News: How Secure is your Wi-Fi?

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Best kids apps for iPhone & iPad

Comment utiliser Twitter ?