DVD's will not autoplay

  DerekL 00:44 01 Mar 2007
Locked

I have a computer with an AMD Athlon XP 2800 and Windows XP SP2. When I open My Computer with a disc in drive D:, it does not display the disc's icon just the name of the disc, and when I right click the CD/DVD drive I don't get "Open" or "Autoplay" in the menu, also when I click on properties and click on autoplay and where it say's "select a content type" it does not show DVD Movie.
When I insert a DVD Movie it just spins and nothing happens, magazine DVD's and CD's start OK most of the time. I have WinDVD installed and I have to open that to watch the movie.
When I open Windows Media Player 10 and click Play-DVD it comes up with a window with the following message.

Windows Media Player cannot play the DVD because a problem occurred with digital copyright protection.

When I click on more information it states you must have a software or hardware decoder to play DVD's.
This has all happened in the last few weeks, everything was fine before that, I quite often make an image of my system for backup and restore it if I have a problem, but my backup has got these problems so I'm stuffed.
Can anybody please help me?

  moorie- 01:02 01 Mar 2007

try this for autoplay
click here
also this for playback
click here

  moorie- 01:06 01 Mar 2007

sorry second link should be
click here

  Fruit Bat /\0/\ 11:48 01 Mar 2007

Autoplay Repair Wizard click here
or
Autoplay disable/enable
1. Click Start, click Run, type regedit in the Open box, and then press ENTER.
2. Locate and click the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom
3. To disable automatically running CD-ROMs, change the Autorun value to 0 (zero). To enable automatically running CD-ROMs, change the Autorun value to 1.
4. Restart your computer.

  skidzy 13:30 01 Mar 2007

If the above fails you,try updating WMP to version 11 click here

then if still problems try the codec pack,this may be your problem of missing or broken codecs. This is the latest codec pack click here

  DerekL 21:40 01 Mar 2007

I only have a dial-up connection because I live in the sticks.
It would take quite a long time to download Windows media Player 11. The other thing is I have a dual-boot system with Windows XP SP2 and DVD's play OK on the second system so it cannot be WMP 10

  skidzy 21:46 01 Mar 2007

Small package is the basic codec pack,this may help click here

  DerekL 20:22 02 Mar 2007

I've tried all your suggestions and still will not autoplay DVD's when inserted I did manage to get back Autoplay and Open back in the menu when I right-click on a CD and in properties then click on Autoplay tab it now shows DVD Movie, Blank CD and Music CD

  moorie- 20:34 02 Mar 2007

if you right click the drive and select properties
select autoplay,select which file type you want to auto play ie and select the app to open it,repeat by file type

  moorie- 21:29 02 Mar 2007

sorry it should of read
ie music dvd etc
ps give the autoplay chance to kick in,i set my youngest daughters pc to autoplay dvd s using power dvd but she just couldnt wait and started clicking away

  DerekL 15:30 03 Mar 2007

I made a mistake in my last response I did not get back Autoplay and Open in right click menu just the content types in Autoplay Tab is now showing DVD Movie, Blank CD and Music CD.
But now it won't play autoplay magazine discs.
I've tried selecting the filetype and selecting the app to open it but that does not work either

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 hack: How secure is your Wi-Fi?

Microsoft Surface Book 2 hands-on review – bigger and 5x faster

Best kids apps for iPhone & iPad

Que faire si son iPhone ou iPad est tombé dans de l'eau ?