DVD/CD Drives

  jessej 13:46 06 Oct 2006
Locked

I have two drives, a DVD and a CD. Neither Auto Runs anymore. The only way I can see what is on a disc in either is by clicking on there respective icons in My Computer, if it is a blank disc then it tells me no disc is in the drive. Device Manager shows both are working properly. In addition I am unable to write to either a DVD or CD. When I try I get the message that no disc is in the drive. Both were working perfectly a couple of weeks ago, to the best of my knowledge I haven't done anything to upset them.
Any ideas please?

  De Marcus™ 13:49 06 Oct 2006

One thing at a time, try the Autoplay repair wizard click here

  jessej 16:29 14 Oct 2006

Many thanks for your reply De Marcus.
Sorry for the delay in replying but I've been stuck in a hospital all week, and have to go back on Monday.
I've downloaded the Wizard and will report back as soon as I am able.

  jessej 17:20 14 Oct 2006

Back again.
Ran the Auto Wizard but it was unable to fix the problem. I case they are of some use I've copied the logs below.


AutoFix [V5.2.3790.67]
Time [2006-10-14 17:09:18]
Microsoft Windows Version [5.1 (Service Pack 2) <2600>]

Test [The Shell Hardware Detection service is running.] - Instance [N/A]:
Result [AutoStart Setting]: OK
Result [The Shell Hardware Detection service is running.]: OK

Test [Policies] - Instance [E:\, Drive Type: 5]:
Result [HKCU\...\Policies!NoDrives]: OK {Absent}
Result [HKCU\...\Policies!NoDriveAutorun]: OK {Absent}
Result [HKCU\...\Policies!NoDriveTypeAutorun]: OK {Present}
Result [HKLM\...\Policies!NoDrives]: OK {Absent}
Result [HKLM\...\Policies!NoDriveAutorun]: OK {Absent}
Result [HKLM\...\Policies!NoDriveTypeAutorun]: OK {Absent}
Result [Driver level policies]: OK {
HKLM\...\Services\cdrom!Autorun (Present) <Allows>
HKLM\...\Services\cdrom\Parameters!Autorun (Absent) <Allows>
HKLM\System\CCS\Enum\...!AlwaysEnable (Absent) <Not set>
HKLM\System\CCS\Enum\...!AlwaysDisable (Absent) <Not set> }

Test [Drive Notification] - Instance [E:\, Drive Type: 5]:
Result [Legacy Notification]: OK
Result [AutoPlay V2 Notification]: Problems {
Service (Fired)
Shell (Deaf) }
>> Repair << [Autoplay V2 Event]
Step: Deleting ShellHWDetection LaunchPermission (HKEY_CLASSES_ROOT\AppID\{B1B9CBB2-B198-47E2-8260-9FD629A2B2EC}!LaunchPermission)
Result: The wizard ran into problems while trying to delete this registry value (HKEY_CLASSES_ROOT\AppID\{B1B9CBB2-B198-47E2-8260-9FD629A2B2EC}!LaunchPermission).

>> Required action: The wizard found problems but cannot fix them -> None

AutoFix [V5.2.3790.67]
Time [2006-10-14 17:04:28]
Microsoft Windows Version [5.1 (Service Pack 2) <2600>]

Test [The Shell Hardware Detection service is running.] - Instance [N/A]:
Result [AutoStart Setting]: OK
Result [The Shell Hardware Detection service is running.]: OK

Test [Policies] - Instance [D:\, Drive Type: 5]:
Result [HKCU\...\Policies!NoDrives]: OK {Absent}
Result [HKCU\...\Policies!NoDriveAutorun]: OK {Absent}
Result [HKCU\...\Policies!NoDriveTypeAutorun]: OK {Present}
Result [HKLM\...\Policies!NoDrives]: OK {Absent}
Result [HKLM\...\Policies!NoDriveAutorun]: OK {Absent}
Result [HKLM\...\Policies!NoDriveTypeAutorun]: OK {Absent}
Result [Driver level policies]: OK {
HKLM\...\Services\cdrom!Autorun (Present) <Allows>
HKLM\...\Services\cdrom\Parameters!Autorun (Absent) <Allows>
HKLM\System\CCS\Enum\...!AlwaysEnable (Absent) <Not set>
HKLM\System\CCS\Enum\...!AlwaysDisable (Absent) <Not set> }

Test [Drive Notification] - Instance [D:\, Drive Type: 5]:
Result [Legacy Notification]: OK
Result [AutoPlay V2 Notification]: Problems {
Service (Fired)
Shell (Deaf) }
>> Repair << [Autoplay V2 Event]
Step: Deleting ShellHWDetection LaunchPermission (HKEY_CLASSES_ROOT\AppID\{B1B9CBB2-B198-47E2-8260-9FD629A2B2EC}!LaunchPermission)
Result: The wizard ran into problems while trying to delete this registry value (HKEY_CLASSES_ROOT\AppID\{B1B9CBB2-B198-47E2-8260-9FD629A2B2EC}!LaunchPermission).

>> Required action: The wizard found problems but cannot fix them -> None


Needless to say I suppose but tried to play discs on both drives after the tests and both failed.

  Fruit Bat /\0/\ 17:32 14 Oct 2006

1. Click Start, click Run, type regedit in the Open box, and then press ENTER.
2. Locate and click the following registry key: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom
3. To disable automatically running CD-ROMs, change the Autorun value to 0 (zero).
To enable automatically running CD-ROMs, change the Autorun value to 1.
4. Restart your computer.

  jessej 10:47 15 Oct 2006

Thank you for your reply FruitBat.
Followed your instructions, under Data the value is showing as 0x00000001(1) so it would appear as though Auto Run is already enabled. Or have I got it wrong?

  Fruit Bat /\0/\ 11:37 15 Oct 2006

Uninstall the drive in device manager then reboot the machine let XP find new hardware and reinstall the drive.

  AragornUK 12:42 15 Oct 2006

Might be a daft question, but do you have any 'multi region' DVD software on your PC? Like DVDIdle or DVDRegionFree? I had a similar problem once and I had set 'Disable Autorun' in this program. It still showed as Autorun enabled in explorer etc, but until I re-enabled autorun in this program I could sit and wait forever and nothing would autorun.

  jessej 13:55 15 Oct 2006

Many thanks FruitBat, that has done the trick and both drives are up and running again.
Thank you for your help, and, of course, many thanks to all others who replied, you've come up trumps yet again.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

ManvsMachine win UK's only Gold Design Cannes Lions award

iPad Pro 10.5in (2017) review

Comment connecter un MacBook à une TV ?