dvd-rw won't work in vista

  Tony 21:58 21 Oct 2007
Locked

The bios and the os see my dvd-rw but vista, media centre or other software can't find a dvd writer to use. I think i had this once on a different machine under XP Pro but never got it fixed. What can I try please?

  skidzy 22:01 21 Oct 2007

Are you saying the dvd drive is missing from explorer Tony.

If so;


1. Click on Start --> Run --> and type in 'regedit' followed by the enter key ( if Vista Start search or windows+R )
2. Expand the "HKEY_LOCAL_MACHINE" key (looks like a folder) by double clicking it (or
3. clicking the "+" next to it.)
4. Expand the "SYSTEM" Key
5. Expand the "CurrentControlSet" Key
6. Expand the "Control" Key
7. Expand the "Class" Key
8. Please look for a key containing the following string of letter and numbers:
{4D36E965-E325-11CE-BFC1-08002BE10318}
9. High light this key by left clicking once on it
10. On the right hand side you are looking for "UpperFilters" and "LowerFilters" under the "Name" column, once you find these please delete them by right clicking on them and choosing "delete"
11. Please exit the registry by clicking on the "X" in the top right hand corner of the screen


Or try this first click here


This is meant for xp,but does work in Vista for some.

  Tony 22:10 21 Oct 2007

It shows on "computer" explorer. It reads dvds fine. on right click, send to - there is no dvd-rw listed. Other software also fails to find a rw.

  skidzy 22:22 21 Oct 2007

Vista, the Send To folder is easily opened by using the Shell command. In the Start Search line of the Start menu, enter

“shell:sendto”

without the quotation marks. Note that there are no spaces in the command and there is a colon after “shell”. When the SendTo folder opens, you can drop in short cuts for any new folders or programs you wish to add. If you prefer to use the old Run line, the shell command works there also.


This should work Tony;

1) start / and type "shell:sendto" without the quotes.
2) Then Goto Computer and drag the dvd drive icon into the menu and close down.
3) You should now have a dvd drive shortcut in your right click sendto command context.

  Tony 07:47 22 Oct 2007

Thanks for you help skidzy. I opened that "send to" window with "shell:send to" as you said and dragged the dvd-rw drive in. It called it "cd shortcut". When I closed the window there is still no dvd on right click, send to :(

I have this problem on two computers. Both are p35 based asus p5k with one xp pro and a new dvd-rw and the other is vista with a six month old dvd-rw that did work on previous amd mobo.

On the vista machine I also tried another dvd-rw in a usb caddy but still the same problem. The os seems to say it is a dvd-rw but no software will see it as that.

  skidzy 18:49 22 Oct 2007

Tony can you check device manager for us please...any yellow exclaimation marks ?

You could try uninstalling them from device manager and reboot and let the os reinstall them.

Did you connect these to the mobo ?

  Tony 19:54 22 Oct 2007

still no luck. But I am very grateful for your help - any other ideas please?
I keep trying too I have even tried a clean install but to no avail.

  skidzy 21:20 22 Oct 2007

Lets start again Tony;

You have done a clean install,which os ?
Have you ran the mobo drivers disc ?

Are you also saying you have no SENDTO in your right click context menu ?

If one machine has this fault,its possible a faulty mobo is to blame.

Can you run this,it will reset your DMA settings over the slower PIO click here

Assuming IDE dvd drive,can you go to Device Manager and find IDE ATA/ATAPI controllers and expand the + sign
Can you post back when is listed under channel 0 and channel 1,right each and select properties this will identify if they are connected correctly to the correct controllers.

  skidzy 21:21 22 Oct 2007

Should read,right click each and select properties.

  Tony 21:45 22 Oct 2007

The clean install was with the vista p5k machine.
All mobo drivers installed from disc.
The Dma test says "No resettable channels with Windows drivers found. Nothing changed."
In device manager.
IDE ATA/ATAPI controllers>
ATA Channel 0
ATA Channel 0
ATA Channel 1
ATA Channel 1
Intel ICH9 2 port Serial ATA Storage Controller 1 - 2921
Intel ICH9 2 port Serial ATA Storage Controller 2 - 2926
All report "This device is working properly"

  skidzy 21:54 22 Oct 2007

Under ata channel 0 and channel 1 properties/advanced settings...what is listed ?

Channel 0 should be the harddrive
Channel 1 should be the dvd drive,possibly recognised as cd rom.

How many drives are fitted in the machine including cd/dvd drives and harddrives.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

WPA2 Hack Latest News: How Secure is your Wi-Fi?

Photoshop CC 2018 released with new Curvature Pen and better brush tools

Best kids apps for iPhone & iPad

Comment utiliser Twitter ?