DVD RW & DVD ROM Drives

  Design Print Studio 21:16 10 Jun 2007
Locked

A friend has recently upgraded to Windows Vista Ultimate on his Advent T11. Now he has upgraded he cannot use his dvd rw or dvd rom drives. They won't come up in My Computer. He asked me to have a look and I went on device manager went on DVD/CD ROM Drives and selected properties and this came up 'Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

Click 'Check for solutions' to send data about this device to Microsoft and to see if there is a solution available' I have checked for the latest driver but I have the latest version. I went on the Pioneer website for the dvd rw drive and i downloaded it but it didn't make any difference.

The devices are called:
PIONEER DVD RW DVR-108 ATA Device

IDE DVD-ROM 16X ATA Device

Can I have a soloution A.S.AP!

  Totally-braindead 21:19 10 Jun 2007

Its Vista you're talking about, did you know theres a forum especially for vista click here

  skidzy 21:35 10 Jun 2007

You may need certain Vista motherboard drivers,check the motherboard for vista drivers.

OR:


This is untested on Vista by me,but has been tested by others and seems to work at times.


Missing cd/dvd drives can be normally associated with the removal of burning software such as Nero/Roxio/Sonic/Easy CD Creator etc.
And not showing the drive in My Computer.


Try the below link ,if still no luck follow the Procedure of removing the upper and lower filters.


click here


If no joy with the above fix,try the Microsoft Guided Help

click here scroll down to the Guided help download and follow the instructions.

If still no joy,follow the manual fix below.

If you have further any error codes,please post them.


Restore Missing CD/Dvd Drives

Missing cd/dvd drive
If it is showing an error code:
Code 19, Code 31, Code 32, Code 39, or Code 41
, delete the drive.

Then follow these directions for clearing the Upper/Lower Filters: (might want to print this out)

1. Click on Start --> Run --> and type in 'regedit' followed by the enter key ( if Vista Start search or windows+R )
2. Expand the "HKEY_LOCAL_MACHINE" key (looks like a folder) by double clicking it (or
3. clicking the "+" next to it.)
4. Expand the "SYSTEM" Key
5. Expand the "CurrentControlSet" Key
6. Expand the "Control" Key
7. Expand the "Class" Key
8. Please look for a key containing the following string of letter and numbers:
{4D36E965-E325-11CE-BFC1-08002BE10318}
9. High light this key by left clicking once on it
10. On the right hand side you are looking for "UpperFilters" and "LowerFilters" under the "Name" column, once you find these please delete them by right clicking on them and choosing "delete"
11. Please exit the registry by clicking on the "X" in the top right hand corner of the screen

Reboot your computer

.If in any doubt editing the registry,please create a System Restore point first and also backup your registry....The guidedhelp from Microsoft on backing up the registry is a good lesson for anyone to learn. click here


Creating a System Restore point:

Start/All Programs/Accessories/System Tools/System Restore…follow the prompts.

  Design Print Studio 21:50 10 Jun 2007

I had to remove Nero OEM 6 Suite prior to upgrade i that helps. Thanks you two for responding so quickly!

  Design Print Studio 18:04 11 Jun 2007

Its all sorted and I can officialy say the case is closed

  skidzy 18:06 11 Jun 2007

can you post the method you used to fix the problem please.This may then help others in the future.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5 review

Alice Saey's mesmerising animation for Dutch singer Mark Lotterman

iPad Pro 10.5in (2017) review

Comment booster votre iPhone ?