DVD player problems (not yet resolved ...)

  Florio 14:14 07 Nov 2007
Locked

I have WINDVD4 on my PC, and it will not play copy protected DVD discs. Non-protected discs play normally. I'm wondering if this is a fault of the program/player, as I cannot remove it from the computer.
I should perhaps mention that in attempting to get my copy-protected DVDs to play I've not only tried various other players (inlcuding Windows Media Player), but have also installed (and subsequently removed) anti-protection software. But all this has proved useless given that the computer inevitably fails to recognise that there is a disc in the relevant drive.
I would reinstall WINDVD4 if I could get rid of the copy currently installed.
Does somebody have an idea of what the problem could be, and of how to resolve it?

  jack 14:32 07 Nov 2007

WindDV4 is I think intergral to the O/S so you will not in the orinary snece be able ro remove it.[Though I dare say a coder among us will say -Oh yes you can- and the go into a method thay I would not dare to go.
But surely a third party DVD player program will play the disc if that is all you are after.
for example click here

  woodchip 14:41 07 Nov 2007

as your DVD player is a new one that does not allow DVD's to run on them It's copy protection. you could fit or use a External if you cannot fit a extra internal dvd

  Florio 15:08 07 Nov 2007

Thanks Jack, but I've already tried the Cyberlink PowerDVD player. The computer refuses to recognise that there is a disc in the DVD drive, and so all the players (and anti-protection software) that I've tried cannot function. But this only happens with copy-protected DVDs.

  pj123 16:32 07 Nov 2007

All commercial DVDs are copy protected, so I don't think that is your problem.

You need to look elsewhere on your system.

  Florio 17:29 07 Nov 2007

I don't know that that's necessarily the case, or at least not all of them have a 'copy protected' label on the case. In any event, I have no trouble playing non copy-protected DVDs on my player.

  skidzy 17:34 07 Nov 2007

Florio will they play through VLC click here

What is the OS on the computer ?

  Florio 17:56 07 Nov 2007

No, I've tried VLC without any luck, I'm afraid.
The same problem: the computer always believes that there's no disc in the DVD drive (but only when the disc in question is definitely copy-protected). I have XP Home, SP2.

  skidzy 18:10 07 Nov 2007

Ok.something to try if not tried already.

Then follow these directions for clearing the Upper/Lower Filters: (might want to print this out)

1. Click on Start --> Run --> and type in 'regedit' followed by the enter key ( if Vista Start search or windows+R )
2. Expand the "HKEY_LOCAL_MACHINE" key (looks like a folder) by double clicking it (or
3. clicking the "+" next to it.)
4. Expand the "SYSTEM" Key
5. Expand the "CurrentControlSet" Key
6. Expand the "Control" Key
7. Expand the "Class" Key
8. Please look for a key containing the following string of letter and numbers:
{4D36E965-E325-11CE-BFC1-08002BE10318}
9. High light this key by left clicking once on it
10. On the right hand side you are looking for "UpperFilters" and "LowerFilters" under the "Name" column, once you find these please delete them by right clicking on them and choosing "delete"
11. Please exit the registry by clicking on the "X" in the top right hand corner of the screen

Reboot your computer

.If in any doubt editing the registry,please create a System Restore point first and also backup your registry....The guidedhelp from Microsoft on backing up the registry is a good lesson for anyone to learn. click here


Creating a System Restore point:

Start/All Programs/Accessories/System Tools/System Restore…follow the prompts.

This fix is not generally aimed at your problem,but removing the upper and/or lower filters will do no harm.

Or try;

1.


Click Start, click Control Panel, and then double-click Administrative Tools.

2.


In Administrative Tools, double-click Computer Management.

3.


In the console tree, expand System Tools, expand Local Users and Groups, and then click Groups.

4.


In the details pane, right-click Guests, and then click Properties.

5.


In Guest Properties, in the Members list, click your user account name, and then click Remove.
Note

If you're using Category View in Windows XP, to open Administrative Tools, click Start, click Control Panel, click Performance and Maintenance, and then click Administrative Tools.

  Fruit Bat /\0/\ 18:11 07 Nov 2007

Make and model of DVD drive? (you can find this in device manager)

You may need to flash the firmware in the drive.

  skidzy 18:11 07 Nov 2007

2nd part should read as follows if this applies;

You may receive this message when you try to play a protected file and your Windows user account is a member of both the Administrators group and the Guests group. For example, if you download a protected file while logged on as a member of the Administrators group, you can't play that file when you are logged on as a member of both groups. To resolve the problem, simply remove your user account from the Guests group by doing the following:

1.


Click Start, click Control Panel, and then double-click Administrative Tools.

2.


In Administrative Tools, double-click Computer Management.

3.


In the console tree, expand System Tools, expand Local Users and Groups, and then click Groups.

4.


In the details pane, right-click Guests, and then click Properties.

5.


In Guest Properties, in the Members list, click your user account name, and then click Remove.
Note

If you're using Category View in Windows XP, to open Administrative Tools, click Start, click Control Panel, click Performance and Maintenance, and then click Administrative Tools.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Alienware 17 R4 2017 review

Interview: Camille Walala on her giant 3D installation inspired by childhood funfair visits

Best iPad buying guide 2017

Où regarder le British Open 2017 ?