DVD player only plays CD-ROMS

  Lincoln-Y 12:48 31 Aug 2005

Hi there, I recently fitted a new hard drive to my 3 year old Packard Bell I MEDIA and installed Windows XP on it and now my DVD player only recognises CD-ROMs. It is a LG/HITACHI GDR-8161B 16x DVD-ROM/40x CD-ROM drive. I have tried updating the driver but windows says I've got the latest already, seemingly supplied by windows rather than the drive manufacturer. LG/HITACHI supply a firmware update but warn it could cause major problems using it on an OEM drive and Packard Bell don't have either. I have Power DVD. It tells me there is no disc in drive when I press play. Windows also tells me to insert disc when I click on shortcut. Any help with this problem would be gratefully recieved, thankyou.

  Stuartli 13:44 31 Aug 2005

The only driver required by a CD/DVD-ROM drive or rewriter is the basic Windows CDROM driver.

The rest is down to hardware or software decoders and you state you have PowerDVD.

Firstly, have you checked the Cyberlink website for any PowerDVD patches or updates - most versions have one available.

Secondly if no matter what you do the drive won't play then it could well be that the DVD laser has gone to heaven with the CD laser battling on all alone.

  sgoku 13:55 31 Aug 2005

i have the same problem.
the dvd drive was working fine under windows xp,
reformmatted the drive and then reinstalled windows XP, and then the DVD dive no longer worked, it will now only read CD's

  Lincoln-Y 14:21 31 Aug 2005

Thanks, I will look for the updates/patches. I might try a laser cleaning disc although by the sound of it the DVD laser has had it. Thankyou for your help.

  Stuartli 14:25 31 Aug 2005

One other possible way is to Uninstall the drive from Device Manager and then reboot.

Windows will Find New Hardware and install its own CDROM driver automatically.

  Cuddles 16:40 31 Aug 2005

I had the same problem, resolved it by downloading firmware update, luckily i had no problems.

  Cuddles 16:41 31 Aug 2005

Why is "view your postings" showing as disabled, is anyone else having the same showing?

  sgoku 16:56 31 Aug 2005

they took it off while they are testing the guy a PC A think it causes errors in the data base so they have taken it off for now

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPhone X review

How to find a font: Discover the name of a typeface with these apps

The best iPhone for 2017

Comment créer un compte PayPal pour payer en ligne ?