dvd drive used by another application

  bob 19:13 08 Jun 2007

I have a problem with my DVD writer. It plays cd`s but if I try to record I get the message `DVD drive used by another application`. I am sure this happened when I put a RW-CD formatted by INCD. I deleted INCD from the add/remove programs and have looked up possible answers in previous forums and tried the Nero General Clean Tool and reinstalled Nero. I still cannot use the writer to write. Is there someone who has had this problem and cured it. I am desperate because I want to copy holiday photos for a friend.

  PalaeoBill 19:24 08 Jun 2007

Did you try the updated DLL from Nero for this problem?

click here

  PalaeoBill 19:27 08 Jun 2007

Oops, sorry wrong link:

click here

  bob 22:00 09 Jun 2007

I have downloaded and I think I have put it in the right place ,but afraid still doesn`t help. If I click the drive message says E://is not accessible. incorrect function

  PalaeoBill 00:17 10 Jun 2007

I had what you are describing when I upgraded to nero 7 from 6. Dropping WNASPI32.DLL into the Nero directory under Program Files fixed the problem. I didn't need to reboot.

  PalaeoBill 00:24 10 Jun 2007

Just had a quick trawl via Google.
Some people have suggested stopping the 'IMAPI CD Burning COM Service' in Services and killing the IMAPIROX.EXE process in the Task List if this is still running.
The service is set to manual on my machine and is not being started and the process does not appear in my task list.
I hope this helps.

  bob 22:19 12 Jun 2007


I`m sorry I don`t know what your talking about,I`m a computer caveman

  PalaeoBill 22:52 12 Jun 2007


If your click on 'Start', then 'Run' & type in explorer.
In explorer, click on 'My Computer' then 'Local Disk (c:)', then 'Program Files'. In the list under Program Files find the 'Nero' directory. Click on that. This is where you should have put the WNASPI32.DLL.

Now, click on 'Start', then 'Settings', then 'Control Panel', then 'Administrative Tools', then 'Services'. Scroll down the list of services and find the one named 'IMAPI CD Burning COM Service'. To the right of the name column, is the status column. If it says 'Started' in here. Right Click on it and select 'Stop'. Right Click again and select 'Properties'. In the 'General' tab, if the 'startup type' is set to Automatic, change it to Manual.

  PalaeoBill 22:54 12 Jun 2007


Do CTRL-ALT-DEL to get the task list up. Select the 'Processes' tab, scroll down as see if there is a process named IMAPIROX.EXE is running. If it is, right click on it and select 'End Process'.

Then try your drive again.

  bob 01:05 13 Jun 2007

I`ve done everything you said and it still will not respond. I am getting to the stage that I think I`ll just throw them away and use a pencil and paper

  PalaeoBill 09:41 13 Jun 2007

Sorry Bob, I am out of ideas.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Fujitsu Lifebook P727 laptop review

11 best portfolio websites for designers and artists

Office for Mac buying guide: Price, Office 2017 rumours & new features

Comment désactiver les programmes qui s'exécutent au démarrage de Windows 10 ?