DVD drive shown as CD ROM - not working!

  gbbg 17:38 16 Apr 2014

Greetings all!

The DVD RW drive on my HP Pavilion dv9700 series (9920us) is not working. Please find the relevant details below:

  1. The drive is Model TS-L632N/HPMH - I think this is Toshiba?
  2. It's detected in My Computer as HD-DVD ROM.
  3. When I try to play a CD/DVD, the light comes on and spins but then shows "Please insert a disk into HD DVD-ROM Drive (F:)"
  4. The Device Manager detects it as a CD ROM and obviously the Windows generic driver doesn't work. The Device Manager picks it up as an "Unknown Device" and is shown as "NCB XYB09 QNKX SCSI CdRom Drive".

The driver is not available on the HP site, so tried the regedit option. I believe I deleted all the strings associated with the driver key!! Then tried the Microsoft tool, which must have installed the generic driver which causes the DVD drive to be recognised as a CD ROM instead. I tried the sfc /scannow as well and it shows that there are corrupt files, which could not be fixed. The laptop works well otherwise.

Please help! Where can I find the driver for the drive? How can I go about fixing this issue?

  Fruit Bat /\0/\ 18:35 16 Apr 2014

Assume you did this...

No CD/DVD or CD-ROM access is missing error Code 19, Code 31, Code 32, Code 39, or Code 41 Try this if the optical drives are not appearing in My Computer or Device Manager. (This is sometimes caused by the removal of Roxio or other writing software.)

click here XP_CD-DVD-Fix.zip and save this file to your hard drive. Navigate to where you saved it and double click the file to extract the contents. Locate the EXE file you extracted and double click it. A confirmation dialog will appear when the script is done. You may need to reboot for the change to take effect. This utility is only intended for Windows® XP, but also appears to work for Vista and Windows 7. You may need Administrator level access to use this utility. If you do not have Administrator level access, the program will say it is finished, but will not have made any changes.

Similar fixes click here works for W7 Vista or XP click here manual fix Run regedit and navigate to registry key HKEYLOCALMACHINE\SYSTEM\CurrentControlSet\Control\Class\ {4D36E965-E325-11CE-BFC1-08002BE10318}. Highlight it and in the right pane, find the Upperfilters and Lowerfilters values. Highlight each one in turn, right click and delete them. Close regedit and restart the computer. If in doubt make a restore point before making changes.


I take it your post on cnet, bleeping computer and techsupport forums hasn't helped?

Download or

  gbbg 18:54 16 Apr 2014

Thanks indeed for the ideas - very thorough. I have indeed tried deleting the Upper and Lowerfilter from the above registry key. In fact I ended up deleting the entire key and all strings, etc...

Could you please finish your message? - you ended on "Download or.."

In the meantime, I'm going to give your suggestions a try - hopefully one of them will work!

  Fruit Bat /\0/\ 19:44 16 Apr 2014

Download or not sure wher that came from this site does some weird things at times.

In fact I ended up deleting the entire key and all strings, etc...

Expains the error then you need the key hut noy yhe upper nd lower filter strings

Did you back up the registry first?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 5T review: Hands-on

Illustrator Andrés Lozano on his improv line work, brazen use of colours & hand sketching

iPhone X review

Comment envoyer gratuitement des gros fichiers ?